Weapon won't fire

X box 1x

Sometimes when looking down sights the weapon will fire without me pulling the right trigger.
Sometimes when looking down sights the weapon will not fire when I DO pull the right trigger.

Automatgevar 4 good
Red dot, extend mag,Barrell ext
Meusser Hunting exceptional
Silencer,4-8 scope,low light/opv
Experimental kpist smg
Ext mag,red dot,compensator
Don’t know if all that is needed.

I have the same problem with all 3.

I am playing by myself in the story mode.

Also when I am using a storage box when storing an item the word store now says “ST” and bring now only says “B”. We’re missing some letters.

The down sights gun thing really kinda sux.

If this is just part of the game then…ok, but not …ok.
I’ll keep playing the game no matter as I love this game for so many reasons. Most of all is that it is so good to feel excited to play a game. I haven’t had that in a while. Please keep making new content. I will buy.


Try using the different controller.

If the issue goes away, it’s the controller issue.

If the issue remains, it could be either console or game’s issue.
To test that, try some other game. If the issue remains in other games as well (whatever action binded under the right trigger does work automatically or doesn’t work when needed) then the issue is with console.

If the issue is only in GZ, after you’ve tried different controller and other games, then it could be said the issue is with GZ.


I have the same issue (not all the time) and on PC with mouse/keyboard.

1 Like

Ok. Learned yet again to buy Microsoft products. My off brand controller is …off brand. I am not having issues with my real Xbox controller. Thank you. It is however weird that I don’t have the same problems when playing Battlefront 2.
Thank you for the help.

Did you try different KB and mouse?

I’m also on PC, with high-end KB and mouse and i have never had this issue.

You’re welcome.

Nope as I have a Razer Deathadder and a HyperX mechanical keyboard, all new so it shouldn’t be an issue.

1 Like

Razer… while popular (reasons beyond me), are plagued by software and hardware issues. Due to my occupation, i know enough about Razer products that i wouldn’t touch any of them even with a 10 foot pole. But that’s me.

Without testing with different mouse, you can not rule out hardware issue.

1 Like

It is usually after reloading the non fire weapon problem occurs , pressing a second time will then fire gun , i have reported this and i have access to 5 Ps4 contollers and this happens on new pad and old pad , it is a bug , it is not your mouse , keyboard , or controller , many have already reported this , cheers :+1: may i add that this is not affecting all users but enough to investigate as a bug

I can confirm, I am on PC and am not able to fire. Reloading the game is not helping either. I noticed it after I had added a gun into a slot. Beforehand I was able to fire normally.
(Still an ongoing bug that needs fixing it seems.)

Care to give us more details by following READ BEFORE POSTING - How to Make a Bug Report guide?

I put everything that I need to put unless you want me to go into full info. So here:

Platform: PC/Steam

Description: After being in game and switching weapons I could no longer fire guns but could swing melee weapons.

Steps To Reproduce: I had put my gun into an empty slot after I cleared my inventory, then took what ammo I needed for said gun.

Images / Videos: Was not able to record.

Host or Client: Steam, East Coast NA

Players in your game: Single Player

Specifications: 64GB DDR4 RAM, Nvidia 1050ti, 2TB HDD, Intel i9 9900k

This asks if you are in solo or multiplayer game and what is your role.
E.g in solo game, you are always Host. And in multiplayer game, if others joined your game, you are Host and if you joined someone else’s game, you are Client.

Lately, i’ve seen similar issue but here, a bit more clarification would be in order:

  • When you equip the weapon in your hot bar in inventory view and then exit the inventory, can you equip the weapon in your hands (seeing the actual weapon)?
    If you don’t see weapon in your hands, instead you see empty hot bar slot when switching weapons, look (1) for below.
  • If you do, look if there is any ammo loaded in the weapon?
    If you don’t, look (2) for below.
  • Have you tested with another mouse/controller to rule out hardware issue?

(1) Sometimes, weapon doesn’t appear in your hand, despite you equipped into your hot bar slot. For me, Fast Travel to different region has fixed it, so, weapon reappears in proper hot bar slot and i can equip it and use it.
(2) When picking up empty weapon 1st and then ammo afterwards, you need to put the ammo into the weapon manually in inventory view, under Attachments -> Ammo section.

Did you only once experienced this issue? Or are you able to reliably reproduce the issue when following what you described?

Ah thank you for clarification. Yes I was alone in my world as host.

When I equipped any of the guns they would appear in my hands and I would be able to aim. I did notice that the ammo was glitched though and was stuck at “50”. It didn’t show the ammo that was on me in the clips. I tested between an Xbox One controller and my Corsair keyboard. I was able to swing my melee with both but not shoot with either.
Completely restarting the game is what fixed it and I haven’t been able to recreate it since.