Weapons in stash no longer show attachments, but as separate non-associated items


#1

Platform: Windows 7 64 Bit SP1

Description: Weapons located inside the stash are not showing their attachments, but rather as separate items in the stash. They also do not show as being associated with any weapon at all while in the stash. When the weapon is transferred from the stash to the player inventory, the attachments come with it, and show as if they are attached to the weapon. This is really confusing when I see attachments in my stash, and have no idea what weapon they are on. It would be less confusing if this behaved similar to pre-patch where the attachments are not separated from the weapon while in the stash.

**Steps To Reproduce:

  1. Put any attachments on a weapon and store it in the stash.
  2. Verify the weapon attachments are on the weapon ( they are not )
  3. Transfer weapon from stash to player inventory. (Attachments come with it)**

**Image: https://imgur.com/Tc9OgQ4 **

Host or Client: Client

Players in your game: 1

Specifications: Client on PC

Other:
Drag and drop was more efficient.
Dragging a weapon to a slot, or ammo to a weapon, or quick attachment swap.
Now I have to: Open inventory > Click on equipped, highlight a weapon > click attachment and swap it out.
Total time, 30 seconds if I’m slow. if I am fighting hunters, I mine as well just let them kill me. God forbid I run out of ammo, then I would have to take 20 - 30 seconds to switch in another ammo type or swap weapons all together. Drag and drop was quick and efficient.
Please bring back the player interface, or make it side by side with the inventory.


Storage box guns not showing attchment
#2

This is something that isn’t that important but I thought it would be worth mentioning. When you put a gun in you storage box with attachments, they don’t show up as being attached to the weapon, all the slots for the weapon attchments are grey, instead of white, showing that there are no attchments on the gun. The attachments are in the attchment section, but again no indication on the attachment that it is attached to gun (the little white triange at the bottom right of the attachment when you have it attached to a gun, only happens when in your inventory, no the box). It also makes it confusing when you take a weapon out and suddenly you can’t move because of the ammo, and you might take a attached attachment out of the box to put it on a nother gun, and the first gun doesn’t have it anymore. Again, this is not very important, but would be more user friendly to newer players, as they may not know where the attachments came from. Thank you for reading in advance.


#3

Platform: Xbox One S

Description: Above

Steps To Reproduce: Put a gun with attachments into your box, everything will be there, just no indication that there is anything attached.

Images / Videos: Will try and get some, will be edited when there are images.

Host or Client: Tried both, same result.

Players in your game: Doesn’t seem to matter, but it has been present with all numbers of charater.

Specifications: Xbox One S


#4

Same issue topics merged.

//Mod