Weapons wheel stoarage glitch

Hi im on ps4 and ive had alot of problems but this ones been the worst like safe houses bieng undiscovered

So basically i was running towards the safe house at Lilla Hammarnäs when i went to put some guns into the storage box i clicked square to deposit all bcs it just deposited weapons that werent on the selection wheel and now my gold grade guns are all blank just gone from everywhere only the outline of them in the selection wheel not even the attachments are there im too afraid to put anything there or it might take them away for ever my baseball bat was also there even though i took it off an hour ago but i still have it in stoarage
It also dlted some of my attachments from my other guns i had a extended mag on my pansvar 90 and now it gone it also took all my dang adrenaline shots

Got to safe house Lilla Hammarnäs go to stoarage and click deposit all in weapons category

Images / Videos:

Shadowranger (my gamer tag is faya247365)

Just me

Idk what Specifications are tbhs

Same thing just happened to me on Dec 10 at approx 2100 MST last night.

World 1, Character 1 - Went to Angeras Church, deposited a few items and next thing I know, I looked at my wheel and 4 or 5 items were blank with the outline of the item. I then looked at my inventory and mostly everything was was gone. After trying to figure things out, I happen to notice an x with the hand underneath the storage box. I tried over and over and over to collect it, by standing, kneeling & crawling prone. Nothing. As I was looking online to see if anyone else had this issue, I just kept trying and finally collected it, but it wasn’t even close to what I had and the hand was no longer there.

I lost thousands of items, including some experimental weapons.

I do truly love this game as there is so much potential, but since the last update with the new glow in the dark stuff, I not only lost the stuff I said above, but right after the update, I also ended up recycling all my weapons in my inventory by accident, because the image didn’t (& still doesn’t) update to the next item after you recycle something. You have to recycle 1 item, then move the joystick down 1 & up 1, for it to update. (Same for moving stuff from inventory to storage & vice versa)

I didn’t mind grinding for my weapons again back then, because most items were gold or less. This time, I’m not sure if I want to go through this again. We spend countless hours grinding for things and this time, it just crushed me.

I really hope that something can be done about the first issue I mentioned.

Xbox Series X