( Xbox ) Good news mission? Tyloveden impossible

Good news mission do not appear on my world .
I have already fast Travel multiple Time at the Mården command bunker , explored lerberget .
I finished ‘‘building blocks’’ mission but i want the tyloveden control point to build a New base in a différent région .

I then decided to go to tylovegen , found a ‘neutral base’ , build a base and the following day when i played the game the control point on the map wasnt there anymore , but my base still.

I destroyed it because it was useless .

Now a Fnix control point spawned , without poiting it on the map

I tried to complete it but non mission appeared and i cant destroy the main generator because i need the C4 to do so.

I cannot reinstal the game because it IS not installed in the first place ( playing from Xbox cloud )

In the Good news Side Mission, you are told to go the Lerang clearing and get 4 pieces of C4.
On the table next to the C4, some coordinates and a few words are written on a piece of paper:
“Tylöveden Forest, N-E hill. The Command Center is the target.”

I know that , but to do what the mission ask me , in need to find that mission , wich IS the issue .

So you tried to do the mission without having the mission?
Well, the mission should popup when you get to the proximity of Lerberget.

But you say you have build a base at tyloveden mountain, which becomes only possible after doing the Good News mission. So there is something wrong here.

Well i did the building blocks mission in the south farmlands which grant access to building bases .
And as i Say , the base point disappeared After

Still, normally you have to do Good news first, then you will be able to build your First base, and later the mission Building blocks was added. Somehow you could do it the other way around, it seems. And that might probably be the reason that Side Mission “Good News” no longer pops up.

I don’t know how to help you…

1 Like

So im fxcked ? Still why would good news be the first mission ? Building blocks littéraly start at the end of the archipelago After the first bunker , weird

I not saying that building blocks couldn’t be done first, but it was added as a tutorial mission, long after “Good News” and “Our new home” (Base building on Tyloveden) was added. Building blocks caused other problems, some people were not able to destroy the command center and could not finish the mission. I am saying that the order you do things might be the cause, but it’s just guessing for me here.

This needs to be looked at.

Well at least i Can build in the others places , i will stay postive and hope for a fix at some point , thanks for your explanations .

I asked about this in Discord, and It seems the mission Good News was replaced by Building Blocks. That would be the reason that you don’t get the mission Good News to popup.

I checked the missions in my log and indeed I can’t find Good News” and “Our new home" anymore. They are no longer in the game. The Tyloveden location is now just like all others a control point which can be claimed without a mission.

Mission count:
Main Missions
(39 Main missions + 9 Alpine Unrest + 10 FNIX Rising ) = 58

(52 Main side-missions + 11 Alpine Unrest + 10 FNIX Rising ) = 73

131 total


Yes, they told that in a dev letter or patch notes.

It was replaced, but if you already finished it there is no need to also finish building blocks.

Edit: I wonder how it looks like if you play with a 100% character as guest in a new players game or vice versa… Which missions will be shown for which players, which can be done and how does it look like if you finished the available one together?

You could have told that earlier. :wink: I did not know they were removed, I thought that just one tutorial mission was added. Now it makes sense how the Tyloveden base disappeared for endgame players. I should start reading the patchnotes… :crazy_face:

@Zesiir this topic is solved…

1 Like