Xbox Series X unable to join friends in Multiplayer

Platform: Xbox Series X

Description: Unable to join Multiplayer via invite or randomly

Steps To Reproduce: I tried joining multiple random games and i had 2 different friends trying to invite me to their games/

Images / Videos: uable to take photos or videos as the game just crashes back to the xbox screen after the audio freezes.

Host or Client: As host they can join me but i am unable to join them

Players in your game:myself and 2 other friends

Specifications: Xbox Series X

I recently just received my Xbox Series X and wanted to play GZ with my friends but i am unable to join with friends only or via invite. I have also tried joining a random multiplayer game with no luck. The game tries but then the audio freezes and crashes to the desktop. If you can provide any kind of an update on this i would appreciate it.


Are your friends on series x? If not then I do not think it will work

That is a very fair point, I have read a lot of the same issue with this as the cause

Thanks for the replies and its what i was figuring on also. Sadly no my friends do not have Series X’s currently. @AliasDJA do you have any links as I personally have been searching for over a day now trying to find that kind of information.

I watched some of the stream and someone asked if gz was on next gen consoles. I think @Avalanche_Pontus said it was not made for next gen yet, but they are looking into developing it.

You’ve got the Xbox Generation Zero group on FB, and as mentioned covered in stream.

I would try getting someone to invite you to game, or can try a good old language lobby search and try get together that way.

1 Like

Thanks again @tomgzero and @AliasDJA I do appreciate the feedback.

1 Like

I’ve played multiplayer on my Series X with people on regular XB1S and XB1X without issue. So I don’t think it’s affecting everyone.

However, I have noticed that if you launch the game and get the “Quick Resume” message in the top right you will have been disconnected from online.

To fix this just open your pause menu in-game and select “multiplayer” this will then ask you if you want to reconnect. Press “OK” and then you should be fine.

Hope this helps!

1 Like

@OBiW4NSHiNOBi Thank you for the input but sadly that still does not work for me. I am so used to my Xbox One X that I just quit the games and have yet to attempt to use Quick Resume on any games. I did however open multiplayer after logging into single player it showed me as in game and tried joining my younger brothers game and I still lockup and crashed back to the Xbox Dashboard I tried this several times with no luck. I tried looking at all my settings and i have multiplayer enabled and everything else.

I’m the same. I don’t intentionally use Quick Resume. It was just last time I played I was playing solo, got a call so just pressed Home to go to the dashboard and turned the Xbox off.

Over a week later after playing other stuff I put GZ on and was suddenly in game, and stood on the runway at the airbase exactly as I was when I quit.

What’s your GamerTag? I don’t play much these days but happy to try join your game / let you join mine just to try and troubleshoot.


1 Like

@OBiW4NSHiNOBi suggested i create a new account so i can have a new game and save file and it worked perfectly i was able to connect immediately to other multiplayer games on me Series X I am not sure if I am able to send my save file into you guys for you to exam it please let me know.

1 Like

I just confirmed the latest patch fixed my issue of not being able to connect using my Series X. Thank You

1 Like

I own a Xbox Series X when I invite me friends to play a game they can join the game when I get a invite from my friend (4 people playing) I can not join but I can play multiplayer with other people I am live at the time.

You can only have 4 players in a game. If there were 4 people in the game already then you wouldn’t be able to join.

Then the host of the game has set his/hers game to “Invite Only”. It’s an option you can toggle in Multiplayer settings, if you don’t want people joining without invitation.

I can’t join my friends who just bought the game. We all have the same update version and I can see them online but the game hard crashes when I try to join them.

Please help…

I’m on an XBOX ONE X and they are both on an Xbox Series S.

Try holding the power button down on your Xbox for 10 seconds to do a hard reset. Then reboot your console and try again.

This usually fixes connection issues for me!

1 Like

So I was able to join one of their worlds and the other guy was able to join as well but I couldn’t see or interact with the second person at all. They also could not see me. It didn’t tell me they were in the server either…the host could see both of us and I could see the host but not our other buddy…

This has happened in the past and we were not able to resolve the matter.

Just played with out being able to see half the team…

It’s frustrating because they like the game alot but this has given rise to major concerns regarding the stability of the game to them…

If we can’t play together they aren’t going to want to keep playing much in the future. Since we were all planning to play together.

What’s worse is they both just spent $50.00 to play this game only to discover it was broken…

1 Like

I’ve had this a fair few times. Usually if the other players (not the host) disconnect and reconnect a couple of times it sorts itself out.

Bizarrely for us, it’s usually “Player 3”, if we get whoever appears as P3 to quit, restart and rejoin it it usually fixes it.

(Although I think this P3 thing is probably just a statistical anomaly for us, rather than a ‘rule’ as it were)

It’s frustrating, that’s for sure. And it’s been an issue for a long long time.

It’s a pain, but try and get all of them to do a hard reset (hold the power button for 10 secs) and start again.

Tbh, if they’re on Series S|X it will takes them longer to hold the power button than it will to reboot! :wink:

1 Like