Aim assist and scope attachment bug (XBOX ONE)


#1

On Xbox One, if I equip an ACOG or 1-4x scope and keep it on the lowest zoom level, the aim moves terribly slow. So slow that I can’t even keep the attached scope on my gun to use.

Also, the aim assist kicks in on dead robots and locks onto them or the tank that was on them, and pulls my aim around or slows it down an incredible amount when turning past it. It also locks onto downed enemies through walls and does the same thing.

At this point I think I’m just going to stop playing the game for a few months till they fix all these issues. It’s evident the game was not properly beta tested for long enough…


#2

Agree. I don’t use the scopes because of that. Just kinda dealing with aim assist problem until it’s fixed.


#3

100% agree with scopes not being able to zoom and Soo slow even when aim speed is 10


#4

So true aim assist needs to be removed


#5

There definitely needs to be an option to turn off aim assist or just stop having the game aim at dead enemies (even the ones that I have fully looted). I really don’t see the point in it at all


#6

I’m sure it wasn’t intended to be that way… the game wasn’t tested long enough before release. I feel like the majority of people who beta tested it were on PC and there wouldn’t be aim assist.


#7

As discussed here and at Disable Auto Aim, I’m playing the game with a Xbox One controller on PC, and a strange auto-aim is kicking in at most inopportune times, mostly when trying to shoot down seekers. I usually use a AI-76 with ACOG/Red Dot scope, and the aim assist snaps on, trails the bot by about half a meter and won’t allow me to lead it properly. Also, as discussed elsewhere, the aim speed is atrocious. I have set it to 10, but at least with scopes there’s no way to quickly switch aim.
I’d appreciate it if you could provide a toggle for auto-aim in the controller options, as I’m sure some players prefer the current setup.


#8

It´s the same on the PS4 , aim assist has been a nuisance since the beginning, i don´t even need aim assistance, not only it´s better without it, but as everybody here understands it , it´s WORST with it.


#9

I always complain about sticky aim wneh fighting stuff, and when I use my lmg, it always gets stuck on seekers when I am trying to aim for a dog or something.


#10

Aim Assist - > OFF

Problem solved


#11

Did I miss the option in-game? If there’s a toggle, please tell me where to find it…


#12

Oh no sorry bud, I meant it as in if they just turned it off - everything would be more fluid.

I also suffer the same problem when I’m one banging with the Magnum.


#13

Phew - was beginning to doubt myself there! Thanks anyways @AliasDJA