Antarctic Jacket - DEVS README - Game is unable to play

I play on ps4, as it is there is a glitch that doesn’t allow you to play your charecter, it gets stuck loading. I’m assuming it’s from the Halloween apparel cause my black Antarctic warrior jacket is invisible on the character select. Not gonna lie I was excited to play and farm but now, for the second time with my experience of this game I cannot play outright due to bugs. Please fix! <3

Luckily this has been acknowledged and we’ll see this fixed as soon as the devs can fix it! for now an apparent work around is to join someone elses game with the character that is glitched you can then remove the jacket and have no problems. :slight_smile: Hope this works for you @Yodunheim !

1 Like

It does I really appreciate it, unfortunately i don’t have playstation plus lmao

1 Like

Dang playstation pinching all our pennies just to play online -.- I’m sorry to hear that, when this is fixed you will see a post about it right away! for now are you at least able to play with other characters?

1 Like

PS Plus? Pinching your pennies? Xbox players has been paying Xbox live gold for years like me and I’m happy they takes my pennies in return, online stability, excellent live online service, freebie games every month, and Xbox live rewards (free live gold, games, etc).

You guys should be glad for PS Plus for many good reasons. They improved a lot better than free online service for PS3.

Anyways, the developers acknowledged this issue and there’s a workaround to this like @tene said.

There’s a thread about this in a few days ago. It’s worth to check it out.

1 Like

now same on PC, after i played with some friends, now i can’t even get into the game. if i choose my campaign, i hear sounds but can naither move or do anything. only got a black screen. in multiplayer i either get an error trying to get to the server or i crash if i get into the server. also my jacket is inviseble, and so is my entire upper body exept my hands and parts of my undershirt.

even tho it got many faults, i like this game. and i whould really like to be able to play.

Hello @Yodunheim and @Antezscar :wave:

Try this workaround to be able to use your character and load into the game:

Hope that helps!

And sorry for the inconvenience. We have a high priority ticket for handling this issue in our bug database. Thank you for your patience! :pray:


tried that with a friend. just now. didn’t work.

Sorry to hear that. It appears the workaround is not working for everyone :frowning_face:

Edit: @Antezscar just to make sure, when viewing your character in character select, is it still wearing the invisible antarctic jacket after you have tried the workaround? If that is the case you might want to try the workaround again, and this time after you have switched to a different jacket, move any item in the inventory (just to make sure that the game saves), then proceed with the workaround (exit to main menu, continue).


hope you get a fix out soon. love your game! hälsningar en norrläning.

by the way isn’t it possible to ‘‘delete’’ the jacket form the game untill you find out what is making it screw up peoples games? just giving ideas.

1 Like

problem is, that the game crashes before i even get the chanse to change clothes.

I have started to suspect all “Antarctic” and/or “Experimental” cosmetic items are causing problem(s).
I got this experimental dazzle jacket, which looks like combat vest. I tried to join friends games, it crashes 3 times a row. Until i removed the item.
But still 1 of the players where wearing Antarctic cosmetic items and the game was so unstable to point that i couldn’t play it.

But in solo game is rock solid for me. I dont even remember when i had crash when playing solo.

is there a way to change clothes without going into a server?

I would say no, if all platform versions work same in menu systems.