Cannot complete Assignments since February Update

No kills for the assignments today are counting, despite following instructions (Ex: Kill 5 ticks with hunting rifle - used 5C Algstudsare with .270 FMJ. Count remains 0/5).


I concur. No assignments are working for me either.


same here, system ps5… no daily missions get counted or finished

1 Like

You should list them more detailed.
Maybe it’s not the whole system, but “some” special assignments. If the devs know which ones don’t work (even if it’s all of a day), they can take a closer look into them and fix them faster, instead of searching for them first.

1 Like

Thank you all for reporting!

1 Like

Semla are in game now. Hagabooda and Klinte.

Semla assignment works perfectly but the standard assignments do not work at all.

1 Like

I have the same issue as well. Using a standard 5C Algstudare with .270 FMJ. No Tick kills recorded.

None of today’s assignments seems to work: Ticks with hunting rifle, Wolf with assault rifle, and Harversters. I did Ticks and Wolf before the update, then I returned for Harvester and they didn’t count; another player has to do all of them, nothing counts (Tick, Wolf, Harvesters).

PC, Steam

New daily assignments no longer track. I have the following 3:

Easy: Destroy 5 Ticks with a hunting rifle
Hard: Destroy 10 Harvesters
Medium: Destroy a Wolf with an assault rifle

I have attempted both easy and hard assignments, destroying 5+ Ticks (tier 1 and 2) with each hunting rifle and 10+ Harvesters (tier 2 and 3), all within Mountains, South Coast and Farmlands. Closing and restarting game had no affect.

Steps To Reproduce:
Nothing beyond the usual.

Images / Videos:

Host or Client:

Players in your game:

Windows 10, Intel i7-2600K, 8GB RAM, NVidia GTX 1070

Adjusted title. This is now the main report thread covering the issue.


edit: easy, medium and hard didn’t work, only the special one: got the semla hat

Same issue. I can accept the FMTEL assignments, make my kills, but they are not registering as completed.
Current time 1:30pm PST
XBOX Series X
Running today’s new update
Single player

ASSIGNMENTS not recording, being playing all to day 21st Feb and 22nd Feb none of the assignments have recorded the achievements, ticks used both hunting rifles must have destroyed 30.
as was the wolf, and no Hunters as well, can you look into it and report back.
anyone else had this problem with this round of.

Also not recording my progress.

Platform Xbox

Moved to thread covering the issue.


i tried the today ones, for me only the easy one worked… the medium (kill 10 military machines) didn’t not :frowning: System: ps5


Same result for me. At least they are sorting it out again.

Add another report that assignments are not recording progress. Today the 10 military machines is showing no progress although the use melee weapons in a base attack and recycling items ones were completed without a problem.

This isn’t a solution, but it is a workaround. I was able to complete the assignment to kill 10 military machines by killing 10 military runners (and possibly one or two military hunters) while doing a base assault mission. I killed 4 in my first base assault and that counted, then killed a bunch outside of the base assault and none of them counted. So I tried one more time during a base assault and completed the mission.


Hi, I have the same issue on pc where the semla pastry acquisition is the only functional assignment. I was playing solo and have not attempted this on multiplayer. This occurred several hours after the update. I did attempt to destroy all machine types in order to record any kills but to no avail.