Did the game become less optimized?

Platform: PC/Steam

Steps to reproduce:
Ever since the latest patch, I’m getting huge frame rate drops and audio stuttering. It happens more or less once every 5 mins or so, and lasts for about 10-20 seconds. Before the patch, I played the game absolutely fine on ULTRA settings without any issues.

Now, even with medium/low settings, I’m still getting these FPS drops and audio stutterings. I’ve tried playing with Steam in Offline mode but problems persist.

Images or video: None

Host or client: Host

Number of players: 1 (I always played solo and hosting my own session)

Operating System: Windows 10 Home 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
Language: Swedish (Regional Setting: Swedish)
System Manufacturer: Alienware
System Model: Alienware 17 R4
BIOS: 1.5.0 (type: UEFI)
Processor: Intel® Core™ i7-6820HK CPU @ 2.70GHz (8 CPUs), ~2.7GHz
Memory: 32768MB RAM
Available OS Memory: 32646MB RAM
Page File: 18690MB used, 14755MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported

Edit: I play the game with an Xbox controller via bluetooth, and use Logitech G933 Headset for audio).

2nd Edit: I lowered the graphics settings a little bit more and the FPS drop and audio stuttering is gone.
Definitely seems like something happened with optimization along the way.

What do you think @ProntoManagement? Should a cpu as spec’d above with a Gtx 1080 play with ultra settings?

Haven’t had that issue. Could it be related to Xbox controllers? Is it Bluetooth/radio connected and loses connection?

Does the robots also freeze or just you?

1 Like

The game still runs but slows down a lot. Graphics and Audio “slow down together” and they both stutter quite bad. My Xbox controller works fine throughout though, I still have control over my character and robots and everything else functions like normal - just much slower/with stuttering.

Edit: Even on lower settings I still get this effect, but maybe it happens more seldom. Still quite regularly though. I’m playing in Steam offline mode right now btw so my guess is that it’s not a connection issue.

Rather strange. Your CPU is great and your GPU is amazing. You’re also running Windows 10. That’s a little strange. @SR_Kimchi might have a clue regarding this.

1 Like

Platform: PC

Steps To Reproduce: Seems to happen at random. Yesterday night the game suttered / lagged like crasy, the day before that we could play for 3 hours without stutter/lag. Only happens to host.

Images / Videos: none, but I can describe how the stutter/lag looks like from the clients point of view since we sit in the same room client can see what happens for both players in the game at same time.
Host: for example running- game paus for about half second. happens alot.
Client: sees the host character running - host suddenly stops and spinning around 360 superfast before continue running

Host or Client: Host

Players in your game: 2

**Specifications Host:
Windows 10 Home
Motherboard: MS-B9071
CPU: Intel i5-7400
GPU: NVIDIA GeForce GTX 1060 3GB

Specifications Client:
Windows 10 Home
Motherboard: MSI MS-B1061
CPU: Intel i7-6700
GPU: NVIDIA GeForce GTX 1060 6GB **

More info: We recently upgraded Host computer from 8 - 16 GB RAM to se if the stutter disapeared. Did not help.
Game runs fine on Client computer.
Both computer max out CPU and GPU usage when game is running.
Client checked VRAM usage while game running. about 4,5 GB VRAM used while game is running.

EDIT 2019-04-29:
The game behaved like this every now and then before the april patch.
It didn't matter who was host and who was client, it was always the same PC,
described above as host, that had stutter/lag. 
We just decided to let her be host always to avoid problems with savegames.

Thanks! I’ll eagerly await his answer! To help things along, I’d like to add that this stutter/FPS drop usually comes when there are robots in the vicinity. I’m almost getting used to it during firefights at this stage.

Noticed that I have started to be moved back a few meters at certain times playing multiplayer. Feels like the host and I have different opinions where my character should be in the world. Strangely it usually happens when about to enter a building.

This is to special attention @ProntoManagement and @SR_Kimchi:

I made some videos on what it looks like when the game drops FPS down to a halt with some serious audio stuttering. In this post, I will call this the “slowmode” of the game, and when the game functions normally, it’s the “normal mode”.

My DxDiag is posted above (the 1st post in this topic) for system specs. I would love some advice as to what I can do to play this game the way I played it before the first patch (i.e. without any of these issues).

Thanks in advance and thanks for your continued support!

  1. In this video I started recording when game was slowed down. One can clearly see the inventory screen and the icon moving slowly, and all animations slowed down when in game as well. Notice that at 00:30 in the video, the slowmode stops and the game is back into normal mode again. The game hops in and out of slowmode once every 2 mins or so. At the end of the video, I show the graphics settings and my own task manager. Note that I have Malwarebytes and Windows Defender active on my computer.

Videos 2) and 3) are different versions of this same phenomenon:

  1. Game puts itself in slowmode much like in point 1) here above. Skip to 1:15 where the slowmode sets in, for a few seconds, and compare with “normal mode” that happens just after
  1. Game starts in slowmode and snaps out of it a few seconds later (at about 00:15)
  1. This video shows a typical game crash for me. Crash at 1:48 (skip video until then). I could be doing anything here, not necessarily in the inventory menu. These sort of crashes where the game halts itself, starts the crash report, and then continues playing for a few seconds happens maybe once every hour but sometimes more frequently.

Apart from the system specs posted here above I am playing with

  • headphones (wireless) Logitech G933 Gaming Headset
  • Xbox controller via the computer’s built in bluetooth
  • I am hosting my own session, playing solo, but slowmode happens regardless if “Anyone can join” is chosen, or if “Invite only” is chosen
  • I have tried playing with Steam in either offline and online mode, but slowmode happens regardless of this setting
  • my Gtx 1080 has updated drivers
  • this issue happened for the first time on the 23rd of April (I remember it well)

I hope you will be able to troubleshoot this issue!
Thank you once again!

1 Like

Could this be related to the NVDisplay.Container.exe bug in the 430.39 series of nVidia drivers?

I can’t see the driver versions people are using but the timing kind of works and there’s a hotfix driver release from nVidia to address the issue now


1 Like

Well Holy Sweet Mother of Jesus and pin me to the wall with a supersonic wedgie and call me Susan!


I installed the hotfix that neither my GeForce program nor NVIDIA control panel told me existed, and now I’ve been playing for several hours without any problems!

Great stuff! :beer: for everyone! :smiley:


tried the new Nvidia drivers with the hotfix.
It didn’t help =(

1 Like

I’m having this issue as well and just a general slowdown of the game since the 1.03 patch. Updating nVidia drivers including the hotfix did nothing.

Prior to 1.03, I was running 4K Ultra detail with 65 fps. When things got a bit heavy, it would drop to the mid 50s. G-Synch still made it pretty smooth and prevented frame rate stutters and tearing. But nmost of the time I’d look at my fps counter, it would be hovering in the mid 60s. At 1440p, I would be hitting 100+ fps. I haven’t eve tried at 1080p, but I can imagine that would be a stupid frame rate.

Since 1.03, I can just barely break 50 fps at 4k, and it will dip into the low 40s when action gets heavy, making it choppy and unplayable. I now have to run the game at 1440p, where I get about 85 fps average, dropping into the 70s when there’s a lot of action.

I have a fairly beefy system running a Ryzen 7 2700x locked at 4.2 GHz, 32 GB RAM, 1 TB NVMe SSD, and an RTX 2080. This is a pretty large dip in performance since the 1.03 patch. I run the video card at stock speeds normally, but now even with an overclock, I can barely break.

1 Like

@Happydust and @Crunchmeister yes you are both correct - my initial jump of joy was made too soon!

I played for an entire day with the issue being GONE but the following day - whoop there it is!

So now I’m using my computer’s support online checker for any odd drivers I haven’t updated as this issue is STILL present! @SR_Kimchi.

I made a post here at this link asking if anyone else was having this issue before making a bug report from it. But I can see I’m not the only one that’s seen a degrade in performance.

And I can indeed confirm that this happened for me right after the 1.03 patch and has been like this since.

1 Like

Hey guys, I had a similar issue myself on my laptop (my desktop has no issues) but someone posted an article on how to fix this if your running off a laptop, your CPU may have suddenly started taking over rather than your integrated graphics card. The 1080 should handle the game like its nothing at all (no issues).

See here on how to fix it and within Nvidia control panel (if you have an AMD GPU then I am so sorry)

1 Like

Thanks @Dracostar but the proposed fix is for peeps who have a separate graphics card apart from the one the computer shipped with. I’m having a 1080 installed already and never bought a separate card, so I’m still waiting for my fix, even after installing Nvidia’s hotfix to their latest driver…

1 Like

Not to get people confused with slowdowns/freezes/stutter/lag.
Possible solution for at least one type of problem.

in my girlfriends case it seem to be what is called stutter.
From her point of view it is like t his

From my point of view it looks like this.

We may have found the solution for this problem now.
in Settings / Graphics / Texture Resolution <-- lower this one.
we lowered from ultra -> high: got a minor stutter. Lowered again from High -> Medium and could play the rest of the session without stutter.
Disclaimer: We have had hour long runs before without stuttering, so we are not yet 100% that this will fix it.

Try with lowering Texture Resolution in graphics setting.
It doesnt sound like you have the exact problem as us, but worth testing out anyway.

@bcatrek it is actually for laptops which have integrated Nvidia GPU’s I had the same issue on my Metabox Gaming laptop and that has hybrid gaming (jumping between cpu and GPU usage) and this fix actually helped me. Did you give it a try to see if it did work? If your laptop has a 1080 already installed then this will work.

Unless yours is a desktop system, then yeah this is only for laptops. I too have a desktop but it runs it with no issue

1 Like