Experimentals not showing up when equipped due to loot complications with FNIX assault rewards

Platform:Xbox One

Description: Experimental Magnum not useable. Every time I equip the exp magnum to the weapon wheel, if I directly select it, the characters hands disappear, and lose ability to fight, but can use either the D Pad or the weapon wheel to select and use any other weapon or item just fine. If I use the Dpad to select the magnum, it skips over that slot entirely and moves to the next item on the wheel. Eg. I have my exp kvm59 at the 12 o’clock slot, and medical first aid kits at the 9 o’clock position. If I place the magnum at the 10:30 location, and use the Dpad, it will switch from the medical first aid kit to the kvm59 or from the kvm59 to the MFAK, but either way it skips the magnum completely. something about the rewards from clearing the FNIX bases is causing the rewarded weapon to be coupled together with other loot items and causing a conflict in the inventory.

Steps To Reproduce: Weapon was a loot drop from a FNIX assault base. Indominus-J pointed out this was an issue with the loot. When I dropped just the exp magnum on the ground, in the bag was a few hundred concrete, a couple hundred copper and the gun.

Images / Videos:

Host or Client:Host.

Players in your game:None

Specifications: Original xbox one, not an s, x or either series version.

Basic troubleshooting done so far:
-Restarted the game, multiple times
-Restarted the system multiple times
-Had to drop the weapon on the ground to get the reward loot to register.

Drop it then pick it up again, anything rewarded from Base Assaults does this


Roflmao, yeah something is broken there. When I dropped it, there was around 350 concrete and 250 copper on the ground with it. God I love this game, but sometimes it makes me wonder if Bethesda did some support for these updates, only thing that can explain the mass of bugs that make it past the QA folks.

I’ll have to edit the post.

Any chance you know of a fix for the other bug that’s been causing me some grief?

If not, thanks all the same, I’ll say a little thank you in your general direction every time I blast a dog or hunter in the grill with the magnum. Well for the first hundred or so kills, can’t promise anything after that.

So when I destroyed a fnix base in southcoast region, I got loot like a kpist experimental but the image in the inventory didn’t appear and I wasn’t able to use it even if I could equip it. What can I do to use it (it was my first experimental :sob:)?

Drop it then pick it up.

1 Like

Thanks, I will test that tomorrow and tell you if it is working

I can´t see my kvm 89 and not shoot it either and i was really exicted to finally try it out but now i can´t because it won´t show like i can equip it too my weapon wheel but when i select it, it only show my crosshair and i can´t reload or shoot. pls fix this quick

Drop it then pick it back up, getting EXP weapons from Base Assaults has always done this.

1 Like

Hey, does the exp 89 not take red dot? I can attach a silence, but no red dot.

The Experimental Kvm 89 can’t attach a red dot, no.

Moved all reports relating the issue to a single thread.


For some reason the crafting materials become attached to the weapon, kind of like when you equip a scope onto a rifle.

1 Like

No scopes for the exp KVM89 because of this part that overheats at the top of the gun and the temperature meter. There is no space for scopes.

No, he’s right. When you get a weapon drop from the base assault (when you attack a FNIX base) it can have a bug where it becomes, well for lack of a better word, bonded to crafting materials in your inventory.

To fix it, what you have to do is drop the weapon on the ground. when you go to open the bag, you’ll also see some of the crafting materials that were in your inventory dropped on the ground with the gun, but after you pick everything back up, the weapon will be useable. It’s a bug that will drive you mad until someone either tells you what to do or you stumble on the solution by accident.

Platform: PC / Steam client

Having an issue where playing in Multiplayer, picking up an experimental weapon and slotting it into a slot causes the weapon to be completely unusable. At first I could assign attachments but that bugged out as well. The only way to re-slot something in that particular slot (once the experimental weapon is assigned) is to unassign the weapon and then assign a known good working weapon to that slot (but again the slot has to be empty for anything to work correctly).

On the flipside, if I pick up an experimental but only slot it after I have reloaded the game into a solo play, the weapon functions as normal. My friend and I experienced the same exact behavior between us in two different sessions. This behavior only seems to occur when slotting an experimental weapon during multiplayer. However, once the issue occurs, the weapon is broken and won’t be functional even after a reboot of the game into a solo session (you can’t even select it in the quick access wheel nor using a quick key like button 3 etc.). I have tried un-slotting and re-slotting, putting the item into storage, pulling it back out, etc. Nothing works once the weapon itself was slotted during multiplayer. The weapon is essentially broken from that point on.

This just happened after the patch came out for the crashes that was recently released as it functioned fine just a day prior to the patch. Not sure if it is related, but definitely sus.

Can this please be confirmed? I now have 2 broken experimental weapons in my inventory that I cannot use no matter what I try. My previously functioning experimental weapons have no issues so this did not affect them. It seems to only happen with newly acquired experimental weapons.


Drop them then pick them back up. EXP weapons rewarded from Base Assaults always do this, and have done since Base Assault was added.

Ok that worked! Thank you for both confirming and providing a work-around!

I sure hope they can do something about a few of these bugs at some point, however I do realize that the game is 3 years old and they are probably heavily focused on the new game release.

Either way, I am set now. Cheers!

Description: kvm 59 experimental in wheel but not in hands

Steps To Reproduce: assigned to slot and select slot

Images / Videos: na

Host or Client: Xbox one

Players in your game: only me

Specifications: I am able to assign the experimental kvm 59 to a slot, but unable to equip to my hands to shoot.

Drop it and pick it up again.

Merged a bunch of reports to this thread.


1 Like