Full dlc reset in game

Platform: PC (Steam)

Description: just logged on and found that all of my dlc weapons go deleted. Like as if my dlcs reset. All of my attachments, weapons, dlc ammo, and gadgets are gone. Is there anything that can be done to reverse this?

Steps To Reproduce: no clue

Images / Videos:

Host or Client: steam

Players in your game: me

Specifications: I don’t think that this is a hardware issue

1 Like

Hi, i made a post previously but go no response.
About 2 days ago I hopped onto generation zero to find that all of my 5C dlc weapons had been replaced with 3 star versions and I had all of the crafted gadgets removed and the standard 5 of each that spawn after purchasing a dlc put in their place. I had never deleted the dlcs and re-downloaded them. Can someone assist me in figuring out how to reverse this?

Creating multiple topics for the same issue in general doesn’t help. It’s just more work for the mods.

@Zesiir: something to merge

I personally don’t see a possible reason, nor a solution. Well, the reason could be that you started a new savegame after deleting the old one, but that would affect more than just your dlc stuff.

I don’t know, but maybe this could help you:

Merged. One thread is enough.


Would I be able to mess with the save file to revert to a previous save? Maybe if I can revert to an earlier save that had the stuff then that might work? I’ll try to see if I can in bout 5 hrs

If you have an old backup savegame file, you can exchange them, of course.
But you cannot manipulate the file to revert something.

Is there a file that has previous saves?

No it isn’t. There is just one savegame.

I see, who would I send my save file to to get checked?

There is all you need.

Yah so I contacted the support and they where no help. And since I don’t have a back up I can’t get everything back. I did a little bit more looking into what changed in my world and it wasn’t just my storage. It was literally everything. It seems that my world and character reverted back to when I had just bought all of the dlcs so all of my progress has been lost. Guess it was a good run. I just now have zero motivation to play at all.

I can understand that.
Losing all is hard.

I just can imagine that it is an issue with your xbox profile. I don’t know how it works on xbox.

For example on Playstation, if I buy a game or a dlc with my main profile, I can run it with my main profile. If I run it with another profile, I should be able to play, but not with my primary savegame.

I’m on pc and the character and world had been opened and closed many times as I logged on and off. I also only use 1 steam account.

A little far fetched, but have you changed the location of the game or the My Documents folder?
This has happened to me too, when the game went back to a save from 2013 or 14 because it couldn’t find the other folder.

Hmmm, do you have steps that you followed for me to try? I’m willing to try it.

At that time I was looking for the “My Documents” folder, when the search showed 2 I realized what had happened, so I copied the old score into the new save folder and it was fine, I had a defective SATA cable to blame, which sometimes worked and sometimes didn’t depending on the position (on the HDD).

I don’t know more now, only that it is highly recommended or rather important to always make a backup of the save folder so that you don’t share or lose everything in the event of a (such) error.

1 Like

I’ll check it out when I get the chance and check back with you with what I find. Thanks for the idea.

I’m a little confused about what file you found in your my documents folder. Was it a copy file of your save?

Sorry I didn’t mean to confuse you. The Avalanche Studios folder is in the “My Documents” folder, where your savegame is saved. If this folder exists twice, the game takes the first one that comes along regardless of the date the save was created.
And the Google translator does not always translate exactly, unfortunately.

I only have 1 file so this doesn’t seem to be the problem