Huge lag on multiplayer (steam version)


I’m making another post here, this time about how I have now got the game with some people that I know. The problem is, and it seems to have occurred before for other people, is that after about 1hr 30 - 2hrs of playtime in multiplayer, I start to get these huge lag spikes (massive fps drops, a bit of stuttering, slowdown) every 5 or so seconds, making the game near unplayable due to how unpredictable they are. My friends don’t seem to be experiencing it but we suspect that it might be due to the fact that they have to run the game at a low framerate anyway. It may also help to know that this does not seem to occur when I am the host, only when I join a friend’s game.

My specs won’t be that useful to know as I can run the game fine on ultra in singleplayer (have done ever since I got the game about 10 months ago) and for about 1hr 30 in multiplayer before experiencing these lag spikes. I have 16gb RAM and a RTX 2060, but as I already said, I don’t think these will help.
Instead I am leaving this here mainly for the chance that a developer may see it and allow it to be patched next update.

The game always is the same, no matter if you play alone or with others with you as host. There is just some more data transfer (upload in general), I guess.

If you are client, the data transfer should be greater on the download-part, because all the info from the hosts game has to be transfered to you.

Maybe your connection speed or stability could be part of the problem?

If the game plays fine when you’re hosting, it’s not an issue with the game. It’s a network connectivity issue. Could be that your internet is terrible, your friend’s internet is terrible, someone is hosting using crappy wifi instead of a hard wired connection or better wifi, or there is just terrible connectivity between you and your friend which is usually relevant to distance.

Yeah, that’s probably one thing I forgot to mention. My internet connection is a bit trash.

Thanks for your help in solving this!

Tried with an ethernet cable, perfectly good connection, still the issue is happening. I don’t think it’s on my end, so I don’t know what’s causing it.

Something else to note is that it happens every regularly - as in I can have about 1hr - 2hrs of gameplay, and only then does it start. Everything before then is fine, and it has only ever happened after this time period (I have tried about 5 or so times, same results each time).

It also depends on how many other apartments/houses still access the same internet line, there are times of the day when almost no one is online (at night/very early in the morning) and times when there is a lot going on (afternoon/evening) depending on .

Edit: It happens in singleplayer too, as it turns out.

I play for roughly the same amount of time, e.g today I played for about 45 minutes and experienced it while scavenging in the Marshlands, and it happens as mentioned before. It’s the same thing - every 3-5 seconds the game drops hugely in performance and stutters constantly, suffering collosal framerate drops and will not stop until I close the game and wait for a while.

It’s getting really annoying, as you may imagine. It didn’t happen before the Landfall update either, if that helps, but since then it has not been fixed. I hope a developer can see this message, as this bug, at least for me, makes the game nigh unplayable for any period of time longer than a short session.

I do not experience said issue in any other game, including ones that require higher performance specs to run.

Had this on ps5 with 2 friends. Went along with multiple crashes for each of us.

We also had infinite ticks in some bases and avoided them by going to the north coast. In Hagaboda we then had fights against a mass of lynx AND gnome ticks.

To me it just seems that Lynxes come in swarms all the time. I have to use the Exp KVM59 and Glock 17 Shock ammo to clear them sometimes. Lynxes are a bit too powerful for what they are in my opinion.