Icons on compass completely stuck, no bicycle or plundra icons


#1

Platform: PC

Description: It appears that the compass is broken and not updating. It shows me only few safehouses (even after restart, some are probably on opposite side of the map), no bicycle or plundra icon.
Icons do rearrange after fasttravel. Some move slightly when riding a bicycle, so they point to somewhere.
Sometimes right after launching the game icon of the safehouse that I spawned in is working correctly, but after fasttraveling to another and back again the icon is gone.

Steps To Reproduce: Check your compass.

Host or Client: Host/client

Players in your game: 1-4

Specifications: i5 4670K, 16G RAM, GTX 1070



Tracking safehouses / rivals not working right
Tracking not working
#2

OK, this is weird.

I picked one of the safehouses with stuck icon, went there on foot. when I moved away from the safehouse the icon disappeared normally, byt didn’t reappear when I went back to that safehouse.

I located all of the safehouses with stuck icons on compass and after eliminating few of them everything started to go back to normal - Plundras, bike stations, bicycles icons appeared as they should.


#3

It’s back :neutral_face:


#4

Got the same myself.
Mostly safehouses where I respawnd are “burned” on the compass.
Fasttraveling there and running out of compassrange lets the icon dissapear.
If to many icons are stuck, no new ones appear. Icons stay on compass, even if
PC is rebootet.


#5

Got the same issue. Not sure when it started, but my compass is next to useless now.


#6

Just do what I did - visit the marked safehouses one by one and it will be back to normal :blush:

From what I’ve noticed it starts after joining a coop game.


#7

More specifically, in MP game, each safehouse you travel to, gets it’s icon stuck on your compass and only way to fix it (remove stuck icons from compass) is to travel to each one of those in your SP game.

This issue has been around for quite a while, since summer of '19 or so.


#9

I’ve had the same issue (I’m on PC), rivals don’t show up on my compass/radar. Some safe houses do, but they are always there. Nothing else appears on it. Kinda annoying because I really liked being able to track rivals without looking at my map every 5 seconds to see which way I need to go…


#10

Platform: PC

Description: On top of screen compass, icons for safe houses stay stuck on it without being able to remove them, these icons are from far off safe houses or phantom houses, clicking “TRACK” on a safe house or trying to “STOP TRACKING” doe snot work, house icon remains.
Related issue: clicking TRACK on a rival doe snot show rival icon on compass top.

Steps To Reproduce:

Images / Videos: 20200626154723_2

Host or Client: Host, solo.

Players in your game: 1

Specifications: v.1858983


#11

Same issue topics merged.

@LoneTiger, read my above reply for fixing the stuck safehouse icons.

//Mod


#12

There is the same issue with radios. Every one that is deployed leaves an icon on the compass.
Limit is 8 - with this many active radios in the game world no other icons will be seen on the compass.


#13

I’ve had a similar issue, but nowhere near as serious as some of you. Occasionally a safehouse icon will get stuck on the compass, but only one has gotten stuck on there at a time. I find that usually when I fast travel to that safehouse and then exit the game, and then reenter it, the issue if fixed.


#14

For me (on PC), i don’t need to exit the game for the icon to disappear. All i do, is taking few steps in that safehouse, so the icon starts moving on my compass. Afterwards, when i Fast Travel out of it, the icon disappears (as it should).


#15

I admit I’m not certain if I’ve tried your solution. It’s been a while since it’s happened to me, so I can’t recall. Next time the bug appears I’ll try your method and see if it works.


#16

The bug can be reproduced quite reliably: all you need to do, is play MP game and travel to different safehouses. Once you get back to your SP game, the icons to each safehouse you traveled to, should be stuck on your compass.

Though, not sure if there is a difference if you play MP as a host or client. I’ve always played as a client and i’ve gotten plenty of stuck safehouse icons on my compass.


#17

Then this is another way that our bugs differ. I’ve never played multiplayer in Generation Zero. I’ve never had anyone to play with. The bug I explained above occurred in single player.


#18

It is possible (e.g when game crashes), that game retains the last few Fast Travel safehouse locations in it and when you boot up your game after a crash, the icons are stuck.


#19

That is a likely possibility. But personally, only one safehouse has gotten stuck on my compass at a time. I can’t say for certain if it’s crash related, as it’s been a while since it’s last happened to me.


#20

Maybe you accidentally clicked on “track” instead of “fast travel” option on the map screen?


#21

Nope. Tried that. Couldn’t get the icon to disappear. Only solution I found was to exit the game while at that safehouse. That… Usually worked.