It's The Final Countdown trophy doesn't unlock

**Platform: Ps4

**Description: I have finished all the main missions, but the trophy “It’s The Final Countdown” does not unlock.

**Steps To Reproduce: finish all the main missions. In case it is relevant, the trophy “rise of the Phoenix” was unlocked i June, when I was a guest in a multiplayer game. Today I finished the last main missions playing solo.

Images / Videos: Uploading: 20191126_194812.jpg…

**Host or Client: Host

**Players in your game: 1

**Specifications: Ps4 Pro

1 Like

I’m on Xbox One and I’ve completed every main mission and yet the achievement didn’t unlock. I’m not entirely sure if the DLC Main Mission are including for the achievement/trophy to unlock.

It should not count the dlc mission, but who knows. I found all the original blueprints yesterday, but did not get the trophy, since they added new blueprints for the dlc. I have never experienced a game where a trophy/achievement for a base game gets harder to get by also count dlc additions.

Same here I completed the game twice once with old update then just a few minutes ago with the 15GB update in September or October not sure anymore its the last trophy I had to delete my old save data just to get a few trophies I couldn’t before and I’m not doing this again please fix this

I’m not sure if this helps or not, but “It’s The FInal Countdown” Achievement/Trophy unlocked for me while I was doing either second or third mission prior to the Hotel’s Defense mission in the DLC. I’m just glad that I don’t have to go through another playthrough of GZ for one achievement that glitched out.

1 Like

Update: So the Trophy unlocked today, after finishing eight of the story missions for Alpine Unrest. The last mission I completed was the visit to the FOA 4 facility.
I’m happy that I got it, but the trophy needs looking into, since it should not unlock at that stage.

Its still bugged even after the patch!
I have been playing since 27 april
And everytime i got stuck i have waited for a fix
And yes i encountered many if not all of them
And the last 1 was the lost and found quest really hoping the new patch would fixed it
And it did but it didn’t gave me my final trophy

I downloaded the patch, entered the game, ‘flying objects’ and ‘lost and found’ had been reset for me, finished both missions, no trophy popped, went to the dlc area because i had 2 story missions left. Finished the first one and the trophy popped for me. The only trophy that is still bugged after almost a year is fashionista

You have to complete all of the main missions on the game itself as well as all of the main missions on the DLC in order to acquire the trophy. I can prove this. I did it myself as well as helped another guy acquire the trophy. The DLC is the only thing stopping you, I can guarantee you that is the case. As soon as we completed The Resistance mission the trophy popped for us. I also completed the fashionista trophy by doing a workaround which took quite a while. In the trophies forum that mentions broken trophies I mentioned it in there.

Edit: ***List of glitched trophies/achievements [PS4/XBOX]***


Playing solo

Got bug too!

All main quest mission in original game is complete, after last update (lost and found fixed), but no trophy “It’s the final countdown”.IMG-1473

For me the trophy unlocked after doing roughly half of the main missions of the dlc.

This bug is still alive and well.

I bought the game about a month ago and have run into this issue. I completed the DLC missions before the base game main missions and I completed Behind the Curtain before some of the other main missions. I ran into the problem where I couldn’t complete Science of Deduction after Behind the Curtain, but, after playing through it in a friend’s multiplayer session didn’t complete it either, I tried it in my own game and was able to complete it giving me the Phoenix title.

I have verified that I have completed all the missions listed as “main” in the wiki.

Very aggravating as it is the only achievement I need for this to be a complete game on Steam (PC).