Kpist Fire rate glitch


**Description:**My Kpist for a little bit did not have the correct fire rate. Either it was a visual and audio glitch. Or the gun itself was glitched. I fixed it by bringing another kpist out that then shot normally.

**Steps To Reproduce:**I was fighting a tank, then switched to my kpist to destroy the tick pod. It then started doing that. I died while messing around with it, then when i respawned it was still there.

**Images / Videos:**

**Host or Client:**I was in a singleplayer game so host.

**Players in your game:**Just me

**Specifications:**MY computer specs are as follows
CPU: Ryzen 5 1400 overclocked.
GPU:GTX 1060 6gb Zotac Overclocked.
Ram:No name 8gb 2400mhz
Motherboard: MSI X470 Gaming plus
Storage: Seagate 120 Barracuda 1TB SSD

I think it is this same issue:

i will try to recreate

So i tried it it did not work. I unequipped my grenades and medkis and replaced the with flares and fireworks. I then put meds back in and shot my kpist no change.

his use of equip is kinda confusing he say equip kpist, i never unequipped it, and still got the glitch so no need to equip.\ the kpist.

I have noticed this Kpist fire mode change couple of time. But has been really hard to reproduce.
And i have just recovered from the problem just by cycling the fire mode couple of times.

hmmm thats the thing with glitches sometimes they are really hard to recreate

In the video, your firing mode is set to Automatic. The gun you take out of the Plundra is in Overdrive. My guess is, you swapped firing modes. You can swap between normal and Overdrive. Y’sure this is a bug?

bruh you can? How the frick have i not noticed this i have 350 hours in this game. You know what yeah you can take this down i am stupid

According to the revelation had in this topic, there is no bug in the game. Instead, game is working as intended. With it, i tagged the topic accordingly and also, close it.