Mouse working in menu but not in-game

new-issue

#1

Platform: PC

Steps to reproduce: Starting a session. Mouse movement works fine in the menu, but as soon as the game starts, impossible to use the mouse.
Keyboard works, the character moves front, back and to the sides but no mouse movement.

Host or client: Both, solo and hosting with 2 other players as well as playing on an other hosts game.

Specs.
Mouse: Logitech g402 and Razer Lachesis (both behaved in the same way)
Windows 10.
GeForce GTX 760
Intel Core i3-4160 3,6GHz
12gb ram


The mouse HEEEEEEEEEEEEEEEEEEEEEEEEEELP
Cant look around
Mouse movement is not working in game
READ BEFORE POSTING - How to Make a Bug Report
Generation Zero Mouse bug
I can't turn around
Beta control bug
I have problems with the mouse, and i like this game
Ma souris ne fonctionne pas / My mouse does not work
Mouse InGame & Menu UI Problem
#2

Platform: PC

Same thing happens to me.

Specs.
Mouse: motospeed v30
Windows: 8
GeForce GTX 750ti
Intel Core AMD A10-7860K 3.60 GHz
8gb ram


#3

Have you tried alt-tabbing out of the game and back in? Maybe try set the game to windowed (or fullscreen if windowed already)?


#4

Yes, I tried it in several ways and it did not work!


#5

Do you have a controller you can test to see if you can look around in game at all?


#6

I do not have, just mouse.


#7

I’ll see if I can find anything for you, hopefully devs can fix this in the mean time :slight_smile:


#8

I have the same problem, but it cannot be because of the mouse because when i use my controller i can still only strafe


#9

Same thing here. Such a weird bug, the mouse even works in the in game menu but as soon as you try to use it to play, it stops working.


#10

Perhaps try a reinstall if you can’t look around at all


#11

Sadly neither reinstalling nor verifying files on steam worked.


#12

Hey @Avalanche_Graham, would you be able to find out anything about not being able to look around in game?


#13

Well same problem. But game tells me to move left stick to move camera. Game engine thinks that I’m playing with controller. But I have no controller plugged in


#14

Thanks for reporting.

A bit of trouble shooting:

  • Will mouse work if you change to windowed mode? (hitting alt+enter to switch)
  • Can you try to change your display settings (screen resolution)?
  • Are your drivers up to date? <— :exclamation:
  • If you open your control centers/panels and fiddle with any mouse settings, will that help?

#15

I’m having the same problem.

Display settings are optimal
Drivers ARE up to date

I looked through setting but don’t see anything that helps with my mouse.

UPDATE: I just tried changing my mouse setting (invert, senesitivity, etc… ) and mouse still won’t work in game.


#16

Same problem with me. All drivers update and it doesn’t work on fullscreen/windowed.

Mouse: Logitech g502


#17

My friend have same problem.

windowed mode don’t fix it.
reinstall mouse driver don’t fix it.
change resolution don’t fix it.
remove gamepad don’t fix it.


#18

drivers up to date don’t fix it.


#19

Trouble shooting part 2 (USB theory):

  • Are you using wireless or wired mice?
  • If the mouse is using USB what else is connected?
  • If you are using USB could you try to disconnect everything and then only connect mouse and keyboard.
  • Could you try switching USB port (Try switching front to back connectors).

#20
  • If the mouse is using USB what else is connected? - microphone, web cam.

  • It’s wired mice

  • We trying connect mouse to other USB port.

    • If you are using USB could you try to disconnect everything and then only connect mouse and keyboard. - Don’t fix.
  • trying other mouse - Don’t fix.

  • In main menu - mouse work

  • In game - mouse don’t work

  • In open map - mouse work