[PC] Settings Not Saving, Can't Continue Saved Game

new-issue

#1

Platform: PC

Steps To Reproduce: When the game starts I only have the option to start a new game. Upon starting the new game and getting to a point where the autosave is run, I can back out to Main Menu and continue my saved game. However, if the game crashes or I exit to desktop I can no longer continue my started game, I only have the option to start a new game and all of my settings have been reverted to the default settings.

I’ve uninstalled the game and will update if this was fixed by a reinstall.
UPDATE
Reinstall did not fix issue.

Images / Videos: NA

Host or Client: Solo

Players in your game:
Solo

Specifications:
Motherboard: MSI Z170A GAMING M7 LGA 1151 Intel Z170
CPU: Intel Core i7-6700K 8M Skylake
RAM: G.SKILL TridentZ RGB Series 32GB (4 x 8GB)
GPU: EVGA GeForce GTX 1080 FTW GAMING ACX 3.0


[PC] Lost my save file
Game not saving
Never Save My PJ
#2

I too am having this exact problem, played for 4 hours and no save. My husband also has the game and is having no problems. I did notice that on his system he has an Avalanche/Generationzero/save folder under documents, but my game is not generating that folder. We have exactly the same system specs running on Windows 10. I tried copying his save folder to my system, but it is still doing the exact same thing, not saving game and showing the option to start a new game instead of continue.

Host or client: Host
Players in your game: Multiplayer- 2 coop

Motherboard: Asus Z270 ROG
CPU: Intel Core i7-7700k
RAM: Corsair Vengeance LPX 16GB 2 x 8GB DDR4-3200
GPU: EVGA Geforce GTX 1080


#3

Hallo I have the same problem :frowning:

Description:
The game is reset every time I start it.
My save is gone and all settings are back to standard.
I’ve tried reinstalling the game and moving it to another hard drive none of that helps.

Hope someone knows what’s wrong, it’s pretty boring to start from new every time.

Host or Client: Playing Solo

Players in your game: Only me.

Specifications: PC
Processor - Intel® Core™ i7-8700K CPU @ 3.70GHz
Motherboard - MSI z370 Gaming Pro Carbon
Video Card - NVIDIA GeForce GTX 1080 Ti
RAM - HyperX 16 GB 2x8GB DDR4-2666MHz
SSD - Crucial MX500
Operating System - Windows 10 Pro


#4

SeEkEr
I too am having this exact problem, played for 4 hours and no save. My husband also has the game and is having no problems. I did notice that on his system he has an Avalanche/Generationzero/save folder under documents, but my game is not generating that folder. We have exactly the same system specs running on Windows 10. I tried copying his save folder to my system, but it is still doing the exact same thing, not saving game and showing the option to start a new game instead of continue.

Host or client: Host
Players in your game: Multiplayer- 2 coop

Motherboard: Asus Z270 ROG
CPU: Intel Core i7-7700k
RAM: Corsair Vengeance LPX 16GB 2 x 8GB DDR4-3200
GPU: EVGA Geforce GTX 1080"

This is very interesting, I wasn’t sure where the save directory should be at. Do you have your Generation Zero and/or Documents directory somewhere other than your C:\ drive? My GZ install is on my F:\ drive but my documents folder is on my C:\ drive. I wonder if there is an issue with the creating and read/writing of the save directory when the install is on a drive other than C:. Just a theory.


#5

I’ve found the save folder in Documents under ./Documents/Avalance Studios/GenerationZero/Saves but sub-directories are empty.


#6

I have the same problem. Dont know how to fix this…


#7

Hello!

Can you all check where your game is saving? The path should be Documents\Avalanche Studios\GenerationZero\Saves

To reliably check if you can save follow these steps:

  • Create a character and load into game (your own)
  • Exit game completely (not just exit to main menu)
  • Restart game

Expected: You should now have an option to “continue”

If you don’t have a save after the above can you tell me

  • your anti virus software, name and version.
  • Window version?
  • Have you placed or pointed your “my documents folder” to another location than the original?
  • Any other software running that could cause interference (Firewalls, VPN etc)

Thank you for your cooperation, we are working to find out what is causing this issue.

@Avalanche_DanM for visibility


#8

HI, first time sorry for my inglish , isn´t my first lenguaje

I play for +10 h and …I cant xave my pj.

all time start again …somebody can help me?

THX


#9

platform:PC

Description: my game is not saving at all.each time i launch the game all my previous progress is gone and the game tells me to start a new game all over again.

Host or Client: Solo

Players in your game: only me
Specifications: CPU:intel i5 7400 3.00ghz
GPU: Nvidia gtx 1050ti 4gigabytes
Ram:8 gigabytes 2400mhz
Motherboard:Gigabyte H110m-S2PH
OS:windows 10 pro 64 bit


#10

Hallo Kimchi.

I found the save and settings folder, but both are empty.

Antivirus - Chili Security
Windows 10 Pro Version 1803

Folder Locatioin
C:\Users\Rune\Documents\Avalanche Studios\GenerationZero\Saves
S:\Steam\steamapps\common\GenerationZero

Software running
Nvidia, Steam, Origin, Chili Security, Corsair LINK, Logitech Gaming Software And Sound Blaster Control panel.


#11

Hi @Avalanche_Kimchi,

Thank you for your response. Just for reference, here are the specs you requested:

  • AV:
    – BitDefender AntiVirus Plus
  • OS Version:
    – Windows 10
  • Pointed My Documents other than Default
    – No
  • Other software
    – None

ROOT CAUSE ANALYSIS
I can’t speak for others, but Kimchi’s AV suggestion made me remember that BitDefender blocks applications from writing to Documents initially. By default, it blocked Generation Zero from writing files but not directories. That would explain why I had the save directories but they were empty. Usually BitDefender pops up a notification that it blocked it but I must have missed it.

SOLUTION
Remove GenerationZero from the list of Blocked Applications in BitDefender to allow it write permissions. The game is now able to write the save files and my settings and character are both saved. I would imagine this is the issue with a number of people’s games not saving. Make sure your AV is not blocking write access to the Documents directory.

Thank you for your help @Avalanche_Kimchi!


#12

Found the problem for ME.

Found out it’s my antivirus that won’t allow the game to change files on the computer.

Message from antivirus translated by google

The generationzero_f.exe program attempted to modify a file in a protected folder and was blocked.
Protected Folder: C:\Users\Rune\Documents\Avalanche Studios\GenerationZero\Saves\76561197971310402
Keep blocking the program if you don’t recognize it or don’t want to edit one of your protected files right now. Only allow the program if you trust the source it came from.
Click the “Learn More” button below for an informative article on data protection and secure files.


#13

Kimchi, ty for the response. My initial problem was the game did not create a documents folder. I copied my husbands document folder to my documents to see if that worked. It did not.
I just now tried starting a new game, load into game, exit to desktop and restart the game. It still does not have the option to continue, just new game.
I am on Windows 10 Pro. My documents folder is the default of the Windows 10 install and I have not placed or pointed it to another location.
The only firewall running is Windows defender, which is allowing Generation Zero both private and public.
No VPN, only software running on startup is Logitech Gaming Software for the mouse and Corsair, iCUE for the keyboard.

The game is installed on my E drive, my husbands is on his D drive. The only difference between him playing vs me, he started playing on unlock before any patches. I was still downloading preload when game unlocked, Just trying to give all the information I can think of between his system and mine.

Thank you


#15

Make sure that Windows Defender is not blocking write access for the game to your Documents directory. You should be able to do this by:
-> Open Windows Defender
-> Open Virus & Threat Protection
-> Open Virus & Threat Protection Settings
-> Find Controlled Folder Access and switch it to Off.

I’m not sure if Controlled Folder Access is configurable by app, I haven’t used it for awhile, but if you can, it’s probably more secure to allow Generation Zero instead of turning it off all together. However just to test, disable the controlled folder access (or even Windows Defender) just to test and see if that resolves the issue. Obviously don’t leave your AV disabled afterwards.


#16

Just an update to the new game option instead of a continue and saving game progress. This is a possible work around or solution for others. Even though I had Generation Zero allowed thru the Windows 10 firewall, there was still something blocking it. After Bubbafrost posted about the Controlled Folder Access, I dug further. I didn’t want to disable the controlled folder access permanently, but I did add an Allowed app through Controlled folder access. It’s under Ransomware protection. Windows 10 Security Ransomware protection lists documents files as a protected folder. It wasn’t allowing the game to access the Documents folder for saves. Once I allowed \Steam\steamapps\common\GenerationZero and chose the .exe, it started saving my progress and settings. I now have a continue game and character option instead of new game only. Husband and I played for over 3 hours and I exited game. Once I logged back in, I still had the continue and character select. Woohoo, now on to playing this fun game. Thanks Bubbafrost for the suggestion.


#17

We’ve noticed some issues with AV software (Bitdefender etc.) preventing Generation Zero from writing saves. To prevent that in the short term please add Generation Zero as a trusted process in the software you are using, we will in the meantime contact the AV software vendors directly to see about us being white-listed as a more permanent solution.


#18

Hello Avalanche_Kimchi,

I can confirm some administrator and AV can block the game from creating folders - I had the issue where my friend had account created playing as a guest on windows 10 and I had issue where my AV (kaspersky) was preventing from writing saves. Quick fix is to change permissions of quest or other accounts and AV profile or to add the game as trusted in AV software.


#19

Some steps for those of you that use Bitdefender:

  1. Open Bitdefender, go to the Notifications tab.
  2. There should be an entry “Application access blocked”.
  3. Expand the message and click on the button “Show application”.
  4. “GenerationZero_F.exe” should be shown in the list.
  5. Click on the toggle button to “allow” access.

The process should be similar when you whitelist the application for other types of AV software.


#20

if that standing ok also check if the cloud syngronisation is on for steam.
I do have a laptop and pc, and laptop did not save, because the cloud save was not on.

now I do have same game on 2 unit’s


#21

Ok here is a fix for win 10 with no other AV beside windows defender

1 Open windows defender
2. Go to ransomware protection
3. Disable protected folder … that should fix on win 10 the save issues for most people

here are som ref images https://imgur.com/a/jzdYW5e

@Avalanche_Kimchi should maybe add this also / repost it so its more visible