Relay Beacon missing

Platform: PC

Description: Relay Beacon missing in SKRANKEBOL

Steps To Reproduce: It just doesn’t show up. I think it’s because we destroyed it in a friend’s game.

Images / Videos:

Host or Client: Host

Players in your game: just me

I’ve seen Relay Beacons respawning if you join a multiplayer session then switch back to singleplayer. Obviously not how it’s intended to be, but it might be a temporary fix.

I just did it and it didn’t work :frowning:

Darn. Sounds like a bug then. Sorry I can’t be of more help.

1 Like

don’t worry, thanks anyway


I have this same issue. I believe my friends and I destroyed this beacon twice, once in a friend’s world, and once in mine (though I was not present when it was destroyed in mine). The objective indicator has not updated and still shows 0/1. Is there a way to force the objective to update? I don’t mind the beacon missing; but, if it’s flagged as destroyed, then the objective should also be flagged yes? I won’t be able to 100% the game otherwise.

I’m playing on PC - Steam. I’ve tried restarting the game a few times.


1 Like

After all the updates that have come out, they still haven’t fixed it ;c