Resistance Radio Maintenance mission bugged, flying building

Hello :wave:, I discovered a bug.
I’m a single player in the game means I’m the host, and I’m use steam version client - PC.

While doing the mission, the building I should use the repair kit is over there in the skies.
I have tried to reopen the game and fast travel to close location but non worked.

1 Like

her are better pictures

:thinking: The radio mast with stairs is missing.

Yup, Xbox Series X happening for me as well.

Same here, the other two are working fine just this tower is missing. I’m on a Series X

maybe it’s the doctor making a landing with the tardis

1 Like

Me too. The first time I was here I didn’t notice the building up in the air. Maybe it wasn’t there? Nah, I probably just didn’t notice it. But I’ve been there three times now, after restarting the game each time, and no luck.

Ps4 too. The game even crashed twice and i tried turning it off and back on again.

Most procedural radio missions are placed on existing buildings in our game. It seems to me that the devs had a building (on that spot where it is missing for us) on their workstations, as part of a upcoming mountain region revamp. I have a feeling that it’s another Water tower or Mining tower, can’t be lighthouse, that would make no sense in the middle of a mountain range. Radio or radar masts we already have in that area. :coffee:

1 Like

Yes, there seems to be a tower/mast missing, I tried shooting the button with the 50 caliber to see if it could be activated from below, unfortunately without success. Too bad

Who knows… Maybe they even thought that it already is part of the game. Why else should there be some parts of that region flattend like there would be structures? :sweat_smile:

:wink: That was kind of what I was implying.
The revamp for the mountain region was long in the planning, until something else took precedence over it. We all identified several pre-adjusted areas where those new control points were most likely have been planned.

1 Like

the 0/6 is still there

Yes, it is. The missing building could mean that the devs are busy with the mountain region, and that it is not a glitch as such, but an oversight that we do not have that building yet in our game version.

I hope that we’ll get several new missions in the mountain region. As well as many new areas to discover and to explore, with exciting opportunities to get a bit more of the story being told.

1 Like


One of locations of radio towers are not drawn correctly - whole tower is missing only top is visible floating in air and enemies to kill are there.
-3192.499, 725.251

Steps To Reproduce:
Got random mission during wandering some areas, started from Tower number 1, next one was #2

Images / Videos:

Host or Client:
solo play.

Players in your game:
just me.

PS5 + internet connection

Platform : PS4 Pro
Description - As presented on screens radio mast that needs to be repaired in quest in levitating in air without textures.
Steps To Reproduce: : Just go the market place on the map (seems few other people also have this bug after new update )
Images / Videos

Host or Client - Host.
Players in your game - 1
Specifications - PS4 Pro

This is a known issue. Moved to existing thread.


the floating building really isn’t that big of a dill, unless you have to press the button, because the Fuse Box & Gas are locations on the ground, looks like a Doctor Who Easter egg anyway

a flying Radio Maintenance Building that travels threw time lol

Did you ever try to take the Delorean (in the same region) to travel to the future of GZ where the missing structure may exist to be able to get to the Tardis, activate it and get back with it to where the mission started?