Resistance Radio Maintenance mission bugged, flying building

It even looks like it have propellers attached with those 2 bits from mast :slight_smile:
Unfortunately at least for me I cant repair/press the button near the generator and locked box, so what ever needs reparing is up there.

Broken for me too on PC. :frowning:
Similar to the main antenna/building at the Overby Air Base which has a transparent roof I fall through.

using a dolorean to reach a un-reachable TARDIS to further complex the time-line even further :rofl::rofl::rofl:, if Marty Mcfly, Doctor Who & Kirrea Cameron were working together like Team Marvel Comics, but with time machines, lol

the floating building really isn’t that big of a dill, unless you have to press the button, because the Fuse Box & Gas are locations on the ground, looks like a Doctor Who Easter egg anyway

unfortunately the generator & fuse box at ground level don’t prompt any actions to do the repair, so there’s probably a button press or similar that has to be done at the top.

Ran into the invisible tower issue today, I need access to the fusebox, which is at the top of the tower. If it was the generator needing gasoline, like it was when I ran this with my boyfriend as host, I could have completed it.
The second tower was the fusebox button and the tower had spawned so I could do that one.

Out of curiosity - if you’re partway through this event and can’t finish it because of the missing tower… will the game refuse to spawn new random events while this one is in “progress”?

No, itll just get rid of this mission and replace it with the next active one when the time comes, which will be tomorrow Sweden time at some point.

1 Like

able to get fuse box this time, cant reach button anyway

Ey jo whats that camo on your weopen ?

It’s always best to paste in the name of the person ( @Echelons-4th-Spy ) from whom you like a reply, other wise your questions can get lost in oblivion.

If you recognise the weapon you can Check Here which camo’s are available for that weapon.

It’s that one:

As you can read, it’s been replaced already and can’t be found anymore.

1 Like

Heavy Flash Custom was accidentally there, was never meant to available

im still waiting for the pink PVG-90 to accentdently slip threw the cracks :upside_down_face: there was also Bepps Cola weapon skin also I would like to see, couple others tenebris shows that I don’t care much for

Will this error (floating building/missing mast) still be fixed? It’s not nice to have a side mission that can’t be completed.

Gladly it’s just a procedual mission which isn’t necessary to complete the story…
But it’s right that this location needs some fixes and I don’t think that the mission itself has an issue, but that the status of the location should be updated.

1 Like

It should get fixed, eventually. Hopefully, sooner rather than later—but, who knows. The devs have been hard at work dealing with all kinds of mission fixes over the past updates, so it should just be a matter of time 'til they get this location working right.

same for me still today i noticed it and wondered what’s happening, bit strange haven’t checked army air base to see if building has been fixed yet but thought i’d also share it

Start the generator and fire a rocket at the button. Worked for me on XboxsX

1 Like

This mission moved to the south coast region for me after the last update on Steam, I was able to finish it there without any problems. I think it was previously in the forest region.

it randomnizes 3 region locations, you might get South region when someone else might get Forest or Mountains, :neutral_face: it also randomnizes Gas, Fuse Box, or Button, :upside_down_face: if your unlucky, you might get the floating tardis in Mountains that requires the Button to be pressed, owell, it is what it is