Stuck on truck mission - Clearing The Path - FNIX Rising

This mission just soft locked me out of finishing the dlc. Same as the post truck has just disappeared. It happened because i joined an online session where the host was just about to the final mission of finx rising. The interesting thing is once i left the session i was able to do the final part of the mission on single player so I have Good night completed but not Clearing the Path

Platform: xb1

Decryption. Basically for the past couple of months of the first missions clearing the path is extremely bugged and I-am unable to continue to the quest line. It all started when i was on the mission when i had to repair the truck after it pulled over at the church when i went to the gas station the game crashed and i was teleported back to the main base. I tried to interact with the truck but i cant click talk to calial and objective says follow calial

Steps to reproduce cant because quest is unable to continue i have restarted my xb1hundreds of times hard reboot and after every update


I was in a single player game offline

No other players cus offline

I have a xbox 1 s

Merged topics. Will poke a dev about the issue on monday.


1 Like

Platform: PC

Description: I need to follow Calle’s truck, even though i’ve completed this quest already in multiplayer, and the truck is nowhere to be found. The marker shows the truck to be at a T junction where a couple tanks were supposed to “ambush” us, but neither the machines to be defeated, nor the truck every spawned for me in single player.

Host or Client: I completed the quest as a client, and have the quest still active in singleplayer.

Map location:

Truck’s missing:

I know this bug has been going on for some time, did anyone got a fix? Can i do anything with this?

I have the same bug on my system. I’d already finished this mission in co-op in another player’s game, and the two of us tried to complete it in my game but ran into this problem. When I opened the doors to start placing items on the truck, there was no truck, but I had the interaction prompts to attach the armor and the snow plow. So we went ahead did that, and the escort mission started (objective “Follow Calle’s Truck”), but there is no truck and not even an icon. Any ETA on a fix? Is it possible to reset missions somehow?


This is the exact thing I have. Atm there is nothing we can do about it. We just have to wait for a fix from the devs.

1 Like

I accomplished the mission “Piece by Piece”, but noticed the truck I was bolting armor to was not visible. Nor was the armor I was attaching.

Upon finishing, I could see the marker for where Calle was standing, and could talk to him but like the truck, he was not visible.

Now, with an invisible not-there truck, I have nothing to follow for the Clearing the Path mission. I can empty the road entirely, but nothing happens.

I’m on a Windows 10 PC with all specs well within recommended ratings.
I can try to pin down exact details for my processor and graphics card shortly.

This whole thing makes that DLC useless. I can’t progress at all.

Same issue topics merged.

Btw, Forum Search still works.


Truck not appearing on the quest Clearing the Path

Platform: Playstation 4

Steps To Reproduce: Play the FNIX dlc all the way through with someone else while you are not host. Next go through the dlc again while you are host and when you get to the quest Clearing the Path the truck will not be there and you can not go any further in the mission.

Host or Client: Host

Players in your game: Just me

Same issue topics merged.


Have you actually been back to check by the scrapyard / church

**Platform:** PC 

**Steps To Reproduce:** Fnix Rising  Follow me Protect the truck mission not sure of the name

**Images / Videos:** The truck is invisible, could see teh hand to start mission that's all

**Host or Client:** I joined somebody else session

**Players in your game:**  2

**Specifications:** Can't see the armoured truck att all in the DLC main mission
1 Like

Same issue topics merged.

Also, @Pallander ,

In rare cases, if a Host travels extremely far away from the Truck and travels back, the Truck will not respawn for the Host, a workaround is to re-create your game session (quit game, then continue)

Patch notes:


Template post (just copy/paste this and fill the blanks);

Platform: ps5
Description: mission wont complete on my game while my bf and I finished all the missions on his. Everything else is ticked off except the first mission Clearing the path/follow calle’s truck
Steps To Reproduce:
Images / Videos:
Host or Client:
Players in your game: 1

Same issue topics merged.


Can’t finish “clearing the path” when finished in another Multiplayer game

This might have been asked before. I played this mission with my wife, the last one where you follow Kalles truck and blow up some fnix stuff, and finished it.
Now when I log into the game on my own and play it solo it tells me that the mission is not finished and that I need to follow Kalles truck…that is nowhere to be found and the garage is empty.
Is there a fix for this?


Same issue topics merged.


Spoilers for the FNIX rising dlc

So I was doing the part where I escort the truck along the road, when my idiot of a friend decided it was a good idea to shoot at the three FNIX class tanks along the road and then leave me. After getting through that, I get to the third checkpoint like area, and after dying I decide to just give up for the day. I come back and now it says the truck is inside the third checkpoint, but the truck is nowhere to be seen. I checked the truck road before and back at the garage, but it wasn’t there either. Is there anyway to restart this mission, or even any kind of fix at all?

Same issue topics merged.


This problem has now been fixed in the feb update. Thanks guys!