Tactical Response Update Change of Load Distance

BUG REPORT AFTER TACTICAL RESPONSE UPDATE. I did not buy today’s new DLC, just did the free update for now.

Platform: PC

Description: Since this morning’s update, I have noticed that enemies do not load into view or sound range until I am significantly closer than I would have been before the update. Indeed, it requires me to be so close to them that most can see me. About the time I first noticed the issue was when a FNIX tank I moved just into range to see, saw me immediately and ran towards me. This not only is very annoying, breaking a major aspect of the game, but means I will have many close encounters suddenly and without warning.

In the farmlands, my favorite sniping area, the sniper rifle is now useless because of how close I have to get to even shoot at enemies and they are upon me in no time. I tried fiddling with the load distance in the graphics settings but that had no discernable effect.

In the uploaded images, I show both map locations for myself and first person views for the farmlands tower I like to snipe from over a large field and the point where I had to walk to get the tank in the 4th image to load into my view so I could see/hear/shoot it. The tank is short of mid field when it first loads and I am a ways into the field, meaning I was really close to it before it loads and appears, making my sniper rifle rather meaningless.

Before the Tactical Response update today, I could stand even behind the tower a ways, or off to the side, and still see distant enemies clear across the same field and close to its eastern border. That means, imprecisely, that the enemy load distance is less than half what it was before the issue manifest itself.

This bug ruins the sniper aspect of the game, and will ruin other related aspects, like the sniping distance stats, not to mention the effect it will have generally on gameplay of not seeing enemies until they are close enough to attack immediately.

Steps To Reproduce: any load distance as far as I am aware, but I noticed it first and most in farmlands region. (see images)

Images / Videos: 4 images: 1-map view at tower, 2-player view at same tower position showing tank not in view, 3-map view when I could first see enemy spawn <mid field, 4-player view at same map position when enemy spawn <mid field.

Host or Client: host single player

Players in your game: one, single player
Specifications: windows 10 64-bit OS, core i-5 7400, 24GB ram, Nvidia 1080 OC GPU, samsung 960 SSD, samsung G9 mega-wide monitor.

Update later in the day:

I uninstalled the game and removed registry entries and game files everywhere I could find them in my documents folder and steam folders and app data folders, etc. As far as I was able to do it, nothing was left of the game on my computer, that I am aware of.

I reinstalled and started a new fresh game, saving my old save game files separately in another location to restore them if this doesnt work. I worked my way over to farmlands region to test the issue. I and am still having issues with machines and objects spawning into view. Although basic enemies seem to be spawning in at the longer distances of 200 to 250 yards, they still disappear farther than 250 yards.

Objects like the ambient tanks, tree stumps, ambient wrecked machines, towers, various structure and buildings and the like often are not spawned in to view even when they should be showing on high or ultra Scene Complexity settings.

In some circumstances, I have to get really close to have them appear, just like with the machines. In some cases, they disappear but show back up as I walk toward them, then disappear if I stop moving, then reappear as I walk toward them again. The moon in the sky frequently disappears and reappears based on my movement of my camera view or position.

Strange, I’m not seeing that, I can snipe enemies over 400m away, at that same tower as in your screenshots, I could snipe tanks 3/4 the way across the open field. Not sure what could be causing the issue on your end, I take it you’ve checked the graphic settings and whatnot?

Screenshot where the marker is at about 250m

1 Like

I changed nothing from before the update to the time when I noticed the bug. Yesterday, my distance to seen enemies was normal. Today, I later changed the settings to see if it might reset anything, though I already knew the graphics settings dont alter enemy spawn/in-view distance. I’ve since verified files (in steam) for the game but that does nothing.

Did you update to the Tactical Response Update? I used to see that far, over 420m, the change after the update today is why I am so frustrated. My longest kill shot stat is 452.76yrds, or 414 meters. Im used to sniping long distance, I do it all the time. But now, most enemies are close to me before I am able to see/hear them. I certainly cannot shoot them when they pop out of existence past the few yards I can see them.

I did some tests to see how far I can now see enemies. I marked the reaper and the map will show me the distance to him. He pops out of existence (visually and his sounds and hitbox) past 250 yards. THAT, is more distance than I am able to see most of the other general mobs in the game. Ive been noticing that most pop into view at a guess of 150-200 yards. Ive seen a few a little longer from time to time and a few that popped into view within less than 100yrds. A few popped into existence pretty much on top of me, or within 25-50 yards or so. That reaper sees me almost as soon as I ever see him and begins to run at me immediately as soon as he pops into existence at 250 yards. Not much warning, to be sure.

If a dev is reading this, I also noticed the “Longest Kill Shot” stat is not updating for my newer characters I have created when sniping with a few different sniper rifles. The new character I have shows 0.00yrds for the longest kill shot even after repeatedly killing machines at both close and far distance. But im not sure if something needs to happen to allow that stat to update for newer characters.

Yeah I have the new tactical update, everything seems to be working there. Not sure what could be causing your issue, there’s a chance a dev might see this, let’s hope it gets figured out for you. Also strange it’s not registering distance on the kill shot stat.

2 Likes

The stats screen always didn’t work as expected, it became even worse with introduction of the new worlds.

1 Like

ah OK, honestly I think I looked at it once and forgot about it until now.

Did you find a solution to this problem? I’m having the exact same issue, noticed it when I was gonna do the last part of the “Eagle Eye” challenge (375 meter kill), which is impossible atm. For me they start rendering in at around 220 meters (240 ish yards).

No, I’ve found no fix or update on this yet. I think SR_Carni mentioned it in a video after the update, but said its not something they can easy reproduce.
I hope they don’t dismiss it that easily though, bcus Ive been playing coop since the update and a ton of people have been having the same problem.

The distance varies. When I first noticed the bug, the max distance I could see was about 190 yards, Later, the distance went up as far as 250, and more recently, its been much less. When I first noticed the bug, i was in single-player, but shortly started playing coop for the first time.
Sometimes, people im playing with are fighting a machine while Im standing right on top of it, but I cannot see it, bump into it, or other kind of interaction or sense of it being there other than seeing other players shooting at the air.
A few times, I can hear the machine, but most times I cant, nor can I see it shooting or any explosions or anything it is doing.
One group we decided to kill a reaper, and the reaper icon on the map screen was showing him way off to the south, and my buddies were talking about attacking this reaper. I was confused. I was walking all through and around the reaper without knowing it was there. Only occasionally seeing my buddies firing at nothing. The reaper suddenly appeared at a much depleted health and I was able to help finish it off, but I had been in the middle of the fight without knowing it was even there for several minutes. This has become a frequent occurrence, with other players killing off whole groups of bots while I am oblivious to what’s even happening.

At this point, the Devs must have noticed this bug themselves, if they play their own game. I love this game, but as much as I’ve been playing since this bug appeared, it has been really hard. If we dont get a fix, this is one bug that will drive people like me to stop playing after a while. Its a very very aggravating bug that radically changes the game experience.

And I also wrote up a new bug today, my ~2-year single-player map Ive been building up since buying the game just lost most of my bases along with all my resources, ammo and health item stores!
This is a significant loss!! I dont enjoy cheating or modding, so for this to happen, I’m about to call it quits if I cant keep my remaining bases or claim any future ones without them being lost randomly too.

Changing the field of view reduces the draw distance. Have you increased your FoV recently?

You can test this by finding the point where a building disappears and move so it just pops back in, then increase the field of view, you’ll see that the building disappears. Reduce it and it will return

1 Like

My FOV is 53 and it was 53 before the bug first appeared. If it is related to FOV, it wasn’t triggered by me changing it.

Thanks though. That was good to mention.

1 Like

I completely forgot about this post, sorry for the late reply.

I have since my last reply upgraded to windows 10, formatted my pc and reinstalled everything and I still have the same issue. I’m pretty sure it has nothing to do with FOV, I have never touched that setting.