Unable to complete mission "Good Night" (FNIX Rising)

In quest " Good Night" can’t loot rivals vision module .
In side quest " In the face of adverity" bike get stuck on 3rd ramp you go over. Tropies pop but don’t get credit for them. Random lag spikes .

1 Like

Merged relevant topics covering the same issue. @Alleybomb, please keep each issue in separate bug reports.


Am having same issue

1 Like

I’m having the Same Issue on PC

1 Like

Good night mission . The Rival is not letting me get the vision module to use as an access key .

1 Like

Merged topics. One thread about the issue is enough. Please follow proper bug reporting procedure.


Update on this status for me anyways - Today the Rival Tank ‘EBBA-02’ respawned on the map location for Good Night mission. This time it dropped the the Rival Vision Module and was able to complete the mission. Don’t know if this is normal for it to respawn or the ‘Dev’s’ quick action to fix the game, if so Kudos to them and Thanks.

1 Like

Interesting. Can anyone else check out of the Rival has respawned, and/or if it can be respawned, and see if that works?

1 Like

Yes, after not being able to access the vision module first time (the hand icon floating pointlessly in mid air for a while after the wrecked machine disappeared), the machine respawned after a restart. Same thing happened again - I looted the machine but the hand icon remained and no vision module. Third time lucky - this time though instead of charging in once the machine dropped and looting everything at once, I selected the vision module only. Seemed to do the trick.

1 Like

Max2, I did the same thing, took the vision module first, verified I had it in inventory and then took the rest of the loot.

1 Like

Everytime I left the Game and Came back the Rival would Respawn and I would kill it and still not get the Module I did this around 5 times and then I brought a Friend in and we killed it and as usual I could not get the Module but he was able to so we were able to Complete the Mission

also I may note in the Mission I’m not sure if it may have something to do with this the Tank also Kept getting stuck on everything the First time I killed it, it was stuck in side the bigger cave by the Overhang right outside of it

Hello everyone :wave:

Is there anyone on PC who is experiencing this mission blocker (unable to complete the mission “Good Night” from FNIX Rising) who’d be up for sending us a copy of their affected save file? It would help a lot in our investigation and efforts to fix this issue.

If you are up for this please follow the steps below.

  1. Your save file can be found here: Documents\Avalanche Studios\GenerationZero\Saves
  2. Right-click the save folder (containing “savegame” and “savegame.bac”) > send to > compressed (zipped) folder
  3. Go to https://wetransfer.com/ (No account required)
  4. Click the “…” button and select “get transfer link”
  5. Add/attach the .zip archive with the save file(s)
  6. Upload and copy the link
  7. Send me a DM here on the forum and include the link from wetransfer

Sorry for the inconvenience and thanks for reporting! :pray:

Same problem on several(not all)ps4 aswell. The vision module is not in the loot in this rival.

I would love to sent you the save file but no idea how to send to compressed (zipped) folded as I don’t seem to have anything like that.

Still can’t complete the good night mission. tank will not drop vision module, tried five or six times and no luck. Tank respawns each time you go back into the mission but will not drop module so can’t complete the game. I am using a computer to play on.

Do you have the salvage skill?

Same issue topics merged.


Hey @Bootsey :wave:

This should be fixed and no longer occur with the next update!

If you are still up for it I’ll gladly take a copy of your affected save file where you are blocked on this mission.

Please take a look at the steps for how to send save files, and especially see step 2.

IF you for some reason don’t have that option it’s ok to…

  • Create a .ZIP archive in a different way
  • Create and send a .RAR archive instead of a .ZIP
  • Send the savegame file (the file titled “savegame”) as it is (in case you can’t seem to create an archive)

Thank you for your time! :pray:


Unfortunately it appears that this issue still can occur after the latest update (December update).

IF you are still affected by this please comment in this thread and consider sending me your affected save file (IF you are on PC).

I have already gotten one save file which reproduces the issue but it doesn’t hurt that we check more save files to ensure that the new fix fixes it for everyone, or at least as many people as possible. If you are up for it follow the steps below.

Sorry for the inconvenience and thank you for your patience :pray:

1 Like