Unable to open building menu

Platform: PC

Description: I am at the Resistance home base and Cannot open the menu to build at this base. I have an error at the bottom that says {enter_build_mode} STRUCTURES , with no key bind displaying for me to bring anything up. I had to go to a stream to see the bind is B. I had already binded B since day 1 to ‘switch ammo’. I tried to revert controls to default, and exiting the game several times in between. I even connected a gamepad and ran it with the defaults there since i never use gamepad. Still same result, the error pops up, although its a bit different with the controller, the error reads " HOLD {enter_build_mode} STRUCTURES. Same with the radio mics, {enter_build_mode}INSPECT. I am at a loss as to what I can do :frowning:

Steps To Reproduce: Used KB/M the whole playthrough, with B binded to change ammo. These are the only parameters I can think of that might be relevant.

Images / Videos: Attached! trouble|596x222

Host or Client: I was hosting a single player game with multiplayer settings set to “anyone can join”

Players in your game: Zero

Specifications: AMD Ryzen 5 1600X Six-Core Processor
16GB Ram
64 bit operating system/processor
Gigabyte motherboard
8gb Sapphire RX 580

For a fix: uninstall the game and then reinstall it. This should reset the key bindings.

ill give it a go and get back to you!

1 Like

I’ve just finished the initial base defence and tried to go into the settings to find the keybind to open the base building menu but I can’t access any of the settings options. If I try to select one I get the click sound to tell me it’s been selected but nothing else happens.

Steam client
Intel i5-4460 @3.2 Ghz
16 Gb Ram
Radeon RX 570 OC
Windows 10 Pro 64bit

Topics merged that have issues with opening the base building menu.

//Mod

Didnt work! I hurt thinking of those GBs going down the drain. I am at a loss, no idea what to do, literally broken for me unfortunetly. Won’t be able to play until a solution happens, thanks guys.

Unfortunately this didnt work. Ill hang tight until someone has an answer. Thanks

I was suspicious of key bindings not being saved in the general data of the game files and them instead being saved in your user profile, which is kept unchanged, even after uninstalling the game. :thinking: At least, now we know.

I know where the user profile settings file is located and deleting that one, then validating game files via Steam, to download a new one, might help. :thinking: HOWEVER, do not do this! At least until dev has come along and said it’s okay to do it. Since i, personally, am not sure if it has any affect on your current save.

Platform: PC

Description: After completing “Good News” mission, the next mission “Our New Home” automatically starts and prompt [B] STRUCTURES is displayed on the screen, when within base range. However, pressing the corresponding button “B” does nothing. Building menu doesn’t appear.
At first, i thought i need to have building materials with me, so i went back and got some of it. Still, at the base area, building menu still doesn’t appear.

Steps To Reproduce:
Go to the base area after “Good News” mission completion. Try to open building menu.

Images / Videos:

With included KB overlay, so video shows that i’m actually pressing the button:

Host or Client:
Host

Players in your game:
1 (myself)

Specifications:
CPU: Intel Core i5-6600K
MoBo: MSI Z170A Gaming M5
RAM: Kingston Savage (4 x 4GB) DDR4-3000
SSD: Samsung 960 Evo (500GB)
SSD: Crucial MX500 (1TB)
HDD: Western Digital Caviar Blue (1TB)
GPU: MSI GTX 1660 Ti Gaming X 6G
PSU: Seasonic PRIME 650 (80+ Titanium)
OS: Microsoft Windows 10 Professional 64-bit Version 20H2 (build 19042.928)

FIX FOR THE ISSUE:

After brainstorming with @Zesiir, we found the fix:

Rebind the “B” key to something else, so, that in key bindings menu, B isn’t binded to anything.

I had the “B” binded to “change fire mode” and after i rebinded to “H”, i can now open building menu.

Video of the fix working:

2 Likes

Didnt work for me, on your screen you can actually see which button to push, but as you can see from this video i cant do a thing!

I’ve seen the similar thing in the forums lately as well, namely in here: N16 aim, offset and as per clarification, that appears when something is binded to a button that game doesn’t recognize.

Here, i have few thoughts:

  • What language your KB is in, under Win settings? Since some languages have letters game may not recognize.
  • Have your tried different KB?
  • Do you use any 3rd party mods?
1 Like

I have an American made keyboard.
I tried a different keyboard, as well as even switching over to a gamepad, and the same problem persists.

The only mod i use is to hide the hud completely (binded to left control)

Perhaps this mod is giving me issues? let me see about uninstalling it and getting back to you!

THIS FIXED IT!!!

Its a mod that acts as a one button hud hider. I removed the files that came with that mod, and viola! I can actually build now, but cant help but be sad that my favorite mod might not work any longer. But so happy this is fixed, thanks for your persistence in solving this with me Aesyle! You ROCK!

1 Like

You’re welcome. :slight_smile:

1 Like

That would probably fix mine as well but I can’t access any of the settings options in the main menu, both in game and from the main screen. All I get is a corresponding click sound. Is there any way to manually add in a keybind to the config file?