Unable to unlock Lilla Hammarnas Safe house

As shown in the image and said in the title I can’t unlock the Lilla Hammarnas Safe house, I completed the mission that guides you to it, I play using the steam version, I can’t tell you the computer specs because I use geforce now. I tried using fast travel and then going back to try and unlock the safe house and restarting the game, neither worked.

People say you need to scout the areas etc apparently the unlock spot is in an odd place there, bit of a bug i guess.

I went into a new world, and indeed the safe house would not unlock normally. I walked all around the area, and then went back inside. I walked to the back wall and jumped toward the window. And it unlocked. Not sure the jumping was needed. :grin:

Hope this works for you too.


Thanks for the advice, it didn’t work when I jumped towards the window, but when I got on the Plundra and jumped out of the safe house I unlocked it.

1 Like

Maybe the trigger was moved up a bit too high after some revamping of the area. It didn’t have unlocking problems a few years back, as far as I know. I can see it now, all new players jumping around the plundra, like a coven of witches around a hot cauldron, trying to unlock it. :last_quarter_moon_with_face:

1 Like

The window trick worked for me thank you! Except for me it was the other window. The building right next to it. The one without the sleeping bag. But the jump was required for me to unlock it, thank you!

1 Like

You can also jump on top of the Plundra, and then jump again - worked for me. It seems the “trigger” for the safehouse to persist is somewhere up in the air… :sweat_smile:

1 Like

The question is:
Did they change the location/safehouse itself when adding the control point west of it, or did they accidently change the invisible box that triggers the safehouse-unlock? :thinking:

Yeah good question… :thinking:

mj_nl helped me figure out how to unlock the Lilla Hammarnas safehouse.

Go by the window over the storage box and Jump

If it still not show on the map, go around the blown up corner of the home and get on top of the red brick wall that remains and jump there.

This seemed to work for My brother, myself, and another PS friend MickeyMouse37