Watch out by dropping weapons!

I just lost a 5-star Hunting rifle and Exp. Kpist, because I was dropping them to re-equip, and the game crashed right after I dropped them, but apparently it managed to save so I lost both weapons. So watch out guys! (PS: I think this is very irrational game design - if the game crashes, at least it shouldn’t save, so the situation is reset when you get back!!) :hot_face::rage:
Any chance the devs have some way for me to get my weapons back I wonder?? :thinking:

1 Like

Ugh, that’s terrible. Hopefully the chances of finding experimental weapons was raised a bit with this update.

The game saves very often. If you observe the upper right corner, every time you do something with the inventory it saves. So I guess it saves the moment you dropped your weapons and afterwards crashed.

So I guess it’s better to drop some non-essential items first before loosing weapons.

Problem is, to be able to equip more than one weapon right now, you have to drop and re-equip. But you can also drop to you storage box, which I can then recommend!


My teammate is experiencing an issue (I play next to her, so can visually attest to this) where, whenever she removes her 5 star 12GA Pump Shotgun from her Plundra, the game instantly crashes. This is repeatable, obviously.

She was able to store the weapon without issue. She also was able to remove every other weapon from her Plundra with no issues - only the Shotgun is causing the crash. The shotgun also has no attachments as far as we know - all attachments and ammo that are compatible with it have been removed from the Plundra.

She is running on PC. This happens in single play and multiplay.

Any ideas or suggestions? She’s swimming in shotgun ammo and has nothing to use it with. :slight_smile:

I have at least one 5* pump shottie too many, that I haven’t even bothered to recycle, if needed (PC)

But first, have you tried to put back all the possible shotgun attachments and the ammo in the Plundra before trying to take the shottie out again?

As it’s stored as a ‘unit’ where currently the attachments don’t show as equipped, it might currently think it’s the old ‘unit’ and due to missing some of it’s parts crash.

Did she put it in the Plundra before or after the new inventory system were added?

She put it in after the new inventory system was added (just last night in fact).

Also, the first crash actually occurred when she tried to remove it with all ammo and attachments still present in the Plundra, as per your suggestion (we were moving her weapons because of the equip bug that happened after the original patch before the hotfix).

Guess it’s quite annoying to have a weapon that crashes the game when touched in the box. I didn’t dare to touch any of my attachments before i sorted all the weapons up on my ‘mules’, to see that they were all intact.

Are there any room to make a new char and try to pick it up from the box? or are there already 4 chars made?

I can supply a 5* pump shottie if needed, but I guess the main priority is to be able to remove a guaranteed ‘game crasher’ from the storage

Yeah, the next thing I was going to suggest was a new character, but I thought I’d report it anyway in the hopes the devs might want to implement a sanity check or something for removing/storing weapons (assuming that’s the issue) since it might have the possibility to affect other people at some point.

Thank you for your advice!

Yeah I added suggestions, in a bugreport, about being able to ‘locki down’ weapons as a unit, don’t make equipped weapons recyclable by mistake without a warning, or accidentally dropped in a looted hunter that flies away, and hide attachments that are equipped from the attachments tab in the box, or at least make it very clear they are attached to something.

Every action with an attachment/weapon are like a ticking bomb right now :slight_smile:

1 Like

Update: She created a new character, and now, when she tries to move the shotgun from her Plundra to her character, she presses E to move it after it’s highlighted in the Plundra, and absolutely nothing happens - it makes the noise, but it stays in the Plundra. She can move her other 5 star PVG90 from her Plundra to her character back and forth without issue - only this cursed 12 GA Shotgun.

1 Like

There is couple of workarounds.

Storage box switching.
Drop weapons.
And latest what i found is instead of using mouse click, click E button to empty and load ammo again into weapon. Allows you to equip it. Little bit finicky process, might need to repeat couple of times, but has worked for me so far when weapon refuses to equip.

Like there is something wrong with mouse clicking items, quick buttons seem to work much more surely.