Assignments not tracking or refreshing. Unable to get new dailies

Same issue topics merged.


Thanks for reporting on this everyone! definitely something we’re looking into!

1 Km isn’t really far, but if you want to track it, put an away point on the map that’s further away than 1 km, and then travel to that point. Also, I think, you have to get of the bike before the assignment can register. I would love to get 4, 6 and even 10 km assignments.

I still have to test if you also can double back, and still get the traveled Km’s.

1 Like

That’s why I travelled vom Iboholmen church to Yttervik and back. It’s about 500m per way.

1 Like

North Church of Ostervik spawns a bike outside.

Keep on the road West, then will naturally head south. By the time you get to the yellow water tower - you’ve done it. No enemies, no stress.


But what’s the fun in that. :crazy_face:

It’s it just me, or does it seems that any time you don’t complete them in one sitting they just break?

Part of me is wondering if there’s an issue with GZ and Quick Resume on the Xbox Series X, as it closes any network activity when you suspend.

Usually I have to start and quit a GZ session before I can attempt any multiplayer stuff as GZ often refuses to recognise that I’m online the first time, even if I quit to main menu before exiting the game.

Well mate I’ll be honest, when I had my X ( I’ll fill you in on that headache in party chat ) I ended up having to re sync every time to get online multiplayer sessions. I always believed it to be my ongoing internet issues and the extra load from the X - but managed to sort that from the mesh kits - and still had the same issue.

Being back on the Scorpio however - no issues at all.

It actually holds an extremely fond memory of his journey and its a nod to it when I get these challenges.

Kind of a trip down memory lane

1 Like

Tried that “no enemies” route, and it worked, but when I past Balders Vall I was met by two tanks and 8 or so hunters. :grin:

1 Like

Ironically, I finished the stream there. You gotta cut the grass to the road south to enjoy the scenery

Mini-report: “Upgrade a Jacket” and “Upgrade 5 Articles of clothing” did not work for me. No change in progress after making upgrades. (PC)

(Other assignments seem to work OK)

I got the schematic still cannot make first aids, use to be able to make them but not there now, went back to see if the schematic are back but no.

Liked the smash the TVs on

I’m now convinced that the dailies don’t persist.

I.e. if you accept them, then turn it off (or crash) before you’ve completed the target. Regardless of how many more hours you’ve got to complete it, the game will never count any more objectives.

Today, accepted both dailies. Then crashed. Went back in and now regardless of how many ticks I brain with the brännboll bat they don’t count.

Have the same problem today.

Upgrade a Shirt did not work for me today (no change in Assignment screen after upgrading shirt).

Same here shirt upgrade did not work
As does the Media packs on this new assignment.

Craft 5 First Aid Kits did not work today.
Recycle 10 items worked as expected.

I think (for me at least) when you get that assignment it means recycle ten items, but not recycle ten sets of, let’s say 100 bullets