Corrupted Save File

I logged into the game save file for a few seconds and had a instant computer crash. Upon relaunching the game it told me my save file has been corrupted and deleted. Not sure what was going on there and not sure how to get the data. Not upset or anything, just a bit of a bummer.

Same issue topics merged.

//Mod

It could be worse, I lost 900h…

Game Crashed, Character lost, weapons lost and mission progress

Hi, I have recently lost my progression on the game, lost all mission status, weapons, and character clothes. I may have been hacked, as the Xbox still shows that I have the add on’s that I have purchased however, they are not showing on the game. Can you assist me any further in getting these back, as I have spent my own personal money on this? many thanks. Casey

Same issue topics merged.

//Mod

Xbox One: My partner on the west coast reached level 16 and I was at Level 15. We signed off 2 nights ago and last night signed on and he could not get into his game. I guess the save bug. He tried to load my character using my login and my xbox one remotely which worked and I tried his remotely and couldn’t log in either. So I think he had no choice but to start over so he deleted his game copy and downloaded it again. Then He got in but had to start his character over, loosing everything.

I just started a new character so we could play at the same level but discovered the map and safe houses and bunkers and missions and what was in my storage case remained. So I went back and stored all my items in the storage box and started the new character again, which gave me access to all my stuff. I then could give enough guns and ammo to my friend so we could restart together. I also downloaded the FNX rising patch and now I host the game were as he was the host.

That bug is real killer as to the enjoyment of the game. We had been playing several weeks, now all gone. We only had a few lockups but nothing serious.

Same issue topics merged.

//Mod

Wednesday, Sept 28, 2020, 19.32H: Savegame corruption after MP

Hail:

I went into an MP to drop off a requested weapon.
After I logged out with my weapon/attachment character/mule, I wanted to get into single player, and continue.
Save file corruption.
I closed the game, I restarted game… and the only option now is Start New Game.

I restored my backup from a week ago (didn’t make much progression since).
This works.

Reason I say this:
Merely notifying I had save game corruption.
What had caused it, I do not know…

Same issue topics merged.

Also, you know very well how to use Forum Search. Question is, why aren’t you doing it?

//Mod


This is the 2nd report i see in the forums where game save has corrupted after using the “mule” char. So, the issue could be there. Using the inventory exploit to carry far excess than what is intended.

1 Like

I did, but the ones I found were posts from '19 and older?
I missed this one, miss, for which my apologies… :frowning:

Could very well be, miss.
Maybe the game closed incorrect for me as client?
A disturbance in the force, perhaps? (network issue)

More like a hint not to exploit the game by using the “mule” char.

For example: i’ve had GZ crashed on me on countless of times and i have very old save, yet, i have never had save file corruption since i don’t use the “mule” char.

Another thought of mine is the game files corruption on the storage drive itself. Since like we all know, nothing lasts for forever and storage drives do fail, eventually. HDDs are far more prone to file corruption than SSDs, especially at the end of their life but SSDs aren’t 100% safe either. Btw, i have my GZ on M.2 NVMe SSD (Samsung 960 Evo).

Plain SSD here, miss, on which my system sits.
Samsung 240GB.

However, what you said is plausible.
Then again, I was just barely over weight limit, so…
I only use it to actually sort things out, miss.

Unlike some, I do not exaggerate in storing on mules…
Still, yes, it could be in fact the mule.
Strange it does not happen more though, seeing I have been giving out stuff quite a bit.


Run into this issue with 240+h into the game and it’s really making me lose my mind. Tried the .bac file and it didn’t work either. Is there anything else I could do? I really love the game, but no way I’m starting all over again

Platform:
PC w/ x-box elite controller

Description:
Was playing along after defeating a couple of tanks and the controller stopped working. I figured something was wrong so using keyboard and mouse started running to a safehouse to save. Didn’t make it. The game froze and didn’t continue or crash to the desktop. I tried to bring up Task Manager but the keyboard was also frozen. I finally had to do a hard reboot to get my computer to work. After that I tried to get back into GZ but had corrupted game files, also the bak file was corrupted.

Not sure if it made any difference but Windows was/might have been updating at the same time.

Steps to reproduce:
None

Images / Videos:
None

Host or Client:
Client

Players in your game:
One

Specifications:
Processor - Intel i7 4770K @ 3.5 GHz
RAM - 8 GB
System - 64 bit
Windows 10
Graphics - GTX 980 Ti

Hello everyone :wave:

First of all I just want to say that we are very sad to see that so many are getting their save files corrupted. This is a huge bummer and know that we are doing our best to prevent this from happening.

We are currently at the point in the investigation where we need corrupted save files from users that haven’t clicked “OK” when the “corrupt save game - restoring of save file failed - do you want to delete your save” message is shown.

Clicking “OK” deletes your save and creates a new, blank save, and a save in that state unfortunately does not tell us anything. However, a save file which is in the state where you get this message on booting the game would be very useful for us in our effort to identify the issue and prevent it from happening.

IF anyone get’s this issue on PC please consider closing the game (via e.g. ALT + F4 or right-click close application on taskbar) when the message is shown instead of clicking “OK”, and then sending us a copy of your corrupted save file.

  1. Your save file can be found here: Documents\Avalanche Studios\GenerationZero\Saves
  2. Right-click the save folder (containing “savegame” and “savegame.bac”) > send to > compressed (zipped) folder
  3. Go to https://wetransfer.com/ (No account required)
  4. Click the “…” button and select “get transfer link”
  5. Add/attach the .zip archive with the save file(s)
  6. Upload and copy the link
  7. Send me a DM here on the forum and include the link from wetransfer

Sorry for the inconvenience, thank you for your patience and thanks for reporting! :pray:

3 Likes

I think the save game process should be altered to prevent this. You basically have a SPOF here.

Consider this process:

  1. Copy the current save file to .sav
  2. Verify the .sav
  3. Copy the current save file to a backup file
  4. Verify the backup file
  5. Save current progress
  6. Verify the current save file
  7. Copy the current save file to a backup file
  8. Verify the backup file

or

Implement a timestamp-based save files with limited amount of save files (10-30) and either load always the latest one.

My 2 cents, 100% frustration reduction guaranteed.

2 Likes


Yesterday everything was ok with my save file but since today when I try to open the inventory of my first character the game crashes

pls help i dont whant to lose the weapons
Kind regards seppi141

Hey @seppi141 :wave:

Thanks for the save. Using it we were able to reproduce the crash you mentioned (occurred on opening the inventory). We’ll take a look and see if we can sort this out for you.

Also, this isn’t really a corrupted save file but something else resulting in a crash, so I’m wondering if you would you be up for writing a separate bug report for this and linking it to me? That would be much appreciated!

Thanks for reporting! :pray: