[Disappearing Weapons] Weapon Disappeared / Despawned

Was out fighting hunters and runners with my experimental .50 cal sniper, and when i equipped my rocket launcher in the slot where my sniper was then tried to re-equip the sniper, the weapon icon when outside of my inventory was showing I still had the rocket launcher on, after a few more attempts i tried to see if i dropped the rocket launcher and equipped the sniper if it would fix it, but after picking the rocket launcher back up the sniper completely disappeared from my inventory, I can still put ammo in it, however it is nowhere to be found in my inventory or stash. I’m not sure if anyone else has had this issue, but i would like to know if there are any known ways to recover the weapons that were lost, it took me a lot of grinding to get that experimental sniper and i don’t want to lose it to a bug.


I am having the same problem my 44 gold special and my auto shotgun gold special are both missing as well i cant find them anywhere

Yuuup! Same issue here sux, oh well hey it’s okay they will patch it next month and you will have it back for an hour before it or somthing else goes missing for a month :stuck_out_tongue_winking_eye::rofl::rofl::rofl::rofl:

Most likely it just sucks i really worked hard to get those

Similar issue, experimental AG4 was not showing in my hotbar and it wouldn’t equip from inventory, so I dropped it, luckily I did not lose it, picked it back up with attachments, tried to re-equip attachment’s, special scope nowhere to be found, if I had lost my full vision module I would of been really annoyed, yep let’s go with annoyed.

Platform: Xbox

Hello @Mastodon_sparkles, @Rasyboat and everyone else :wave:

Sorry to hear about this, it is not something that should happen and I understand it must be quite frustrating to experience it.

We have a high priority ticket for this issue in our internal bug database, however, we could use some more information when it comes to reproducing the issue and finding out how it occurs.

If you are experiencing the issue please try to answer as many of the following questions as possible:

  1. What platform are you playing on?
  2. Were you in a single player session or multiplayer session? IF multiplayer, were you host or client?
  3. Do you remember what you did around the time when it happened, or what actions may have caused this to occur? Any information could prove useful, even if it is vague.
  4. IF anyone playing on PC is having this issue and could send us a copy of your save file it would help a lot in our pursuit to handle and prevent this issue from occurring. If anyone can provide us with an affected save file please send me a DM here on the forum.

Your save file can be found here:
Documents\Avalanche Studios\GenerationZero\Saves\YOUR_STEAM_ID\

Thank you for your time, your patience and sorry for the inconvenience! :pray:

1 Like

I was on Xbox 1x
Single player
I logged in, that was it, it was missing from hotbar when I logged in.
It was showing in my inventory, but wouldn’t equip.
Dropped on the ground and picked up, after that attachment was missing (special scope) for AG4

I was playing on ps4 slim 1tb.
Mutiplayer 3 pp, my friend was host.
Se did a mission on as seen on the picture below, that was a weapon to be found in a sitting soldier that har a AG 4 or 5 that you could collect. I had all the attachments for my Experimental Pbg 90 and was corrently aquipted with that weapon when i took up the weapon laying beside the soldier, suddenly my sniper disapered? Didn’t find it anywere, so i did a couple of more missions. Found a new Experimental Pvg 90 and now my inventory shows when im gonna attach bullets to the sniper that i got 2 Experimental Pvg 90? I only got one in my inventory and non in my chest.! X marks the spot where it happend for maybe 3 weeks ago!?


1 Like

GZ Team,

Platform: XBox1/Single Player (But somehow people were joining and leaving)

Issue: Exp. 50 disappeared from equip slot one and inventory.

Activity: FOA final main mission. Died used survivor ability to revive and my weapon was gone.

i get the exp pump/shotgun yesterday and today him disappeared
please help my Systemic Reaction
platform: pc
im play on single player
not have images.
thank you

1 Like

i was fighting some apocalypse runners and ticks and hunters the other day, and a ex pvg 90 that i had just traded dissapeared right out of my hotbar along with its attachments. i did not drop it, i looked for 3 hours for that sniper rifle and couldnt find it. then, yesterday, my ex ag4 with attachments dissapeared from my hotbar while i was in a bunker doing a mission with a guy who was new to the game. i looked at every square inch of that bunker and could see if i had dropped it. i am so very annoyed cause those were my favourite weapons. if anyone can help please do.

Hello @CloudFire and everyone in this thread :wave:

First of all, sorry to see several of you having lost weapons due to this bug. We understand your frustration and consider this among one of our most serious issues on the live game.

A while back we dug into the topic linked below and since then we have done partial fixes to prevent the unintentional dropping of weapons (further fixing for that should roll out with the next update);

However, we have seen an increasing number of these reports of weapons disappearing/despawning from the inventory/equipped slots, for no apparent reason. And, for some reason the PVG90 is overrepresented in these reports (maybe simply because it is a popular weapon that you notice if it disappears?).

We have a ticket for investigating this and in the meantime we’d really appreciate it if you continue sharing information and reports of this as it really helps us trying to figure out what is happening here.

Some examples of information that we’d be interested in;

  • What platform are you on?
  • Do you play the game offline? Is the game updated with the latest patch or are you running an older build?
  • Did this happen in SP or MP? Do you play SP only or a mix of SP/MP?
  • Was the item that disappeared equipped to a quick slot or was it just in the inventory or plundra?
  • Did you see it disappear? When did you notice that it was gone?
  • What was the item that disappeared / despawned?
  • What was the last things you did before the issue occurred? Did anything out of the ordinary happen? Anything in particular that you think may have played into it or even caused it?
  • Anything else that you think might be relevant or of interest?

We understand that this is a difficult issue to capture on video, BUT if you happen to get it on video we’d be really interested in getting a copy of that for the investigation.

Again, sorry for the inconvenience, and thanks for reporting! :pray:

1 Like

I play on Xbox series x. I was playing single player, an I found a new level 3 scope. I picked it up an when I went to equip it I hit Y on the gun I want to equip it to an I hit Y twice on accident but it shouldn’t have done anything besides bring me to equipping option for that gun an all of a sudden I noticed my other rifle I was hanging on to had disappeared. This happened to a sniper rifle as well when I first started playing this game… This makes me not want to play the game until this is fixed or I risk losing good weapons.

Moved to existing topic.


I experienced a bug when I unequipped my experimental Pansarvärnsgevär to equip my experimental shotgun it disappeared.

1 Like

There is an existing topic for this issue. Please search, people.


Platform: Xbox One X

Description: Me and my wife were playing together and all I did was change weapons from my main to my side arm and weapon vanished out of my inventory including ALL gold attachments. And then my wifes experimental disappeared in the same session. WTF?

Steps To Reproduce: did the same exact thing I did switched from main to side arm. thats what I did when it happened. My wifes experimental AG4 just vanished. 2nd time its happened. and I didnt drop it we scoured the area. Makes me not even want to play the game anymore. We spend hours playing this is a no go. thanks for being on top of this.

Images / Videos: Wasnt expecting it to happen nothing.

Host or Client: I was hosting. I know you can see what happened and exactly where I was.

Players in your game: 2 Me and my wife

Specifications: Xbox One X

Hello. Tell me, did the weapon suddenly disappear from the inventory? PS4 Pro. I faced a similar problem on the island of Saltholmen, I did everything in a backpack, I wanted to equip garantgevar m/49 (5*) instead of the experimental ag4 in slot number 1, ag4 disappeared, there was an empty cell left. Then I decided to do the same with the second slot, KVM59 (5*) was in it and it also disappeared, but everything remained in the inventory. I couldn’t install anything in these two slots, Klaucke 17 (5*) remained in slot number 3. I didn 't know what to do and decided to return to a safe place .I decided to put my weapons in the plundra box and take them back. After I did this, everything returned to its place and I didn’t have to restart the game. Perhaps this information will be useful to someone!

Same problem here!! 4 times 5* and experimental weapons have vanished. I was just changing weapons and my main just disappeared 5* hp9 then 2 minutes later my wifes experimental AG4 just vanishied and she was just looking at her inventory. they dont cart my man. they will claim you dropped it or something but I was just running and switched weapons. and poof like majic a gun Ive had for a month now.


I don’t understand the problem as I didn’t have this at all in just 8 month.

But me and my coop-partner at the beginning sometimes had the problem that we pressed the wrong button while looting a dead machine or something else.
The loot-menu and the inventory work a bit different.
So sometimes we accidently dropped weapons into dead bodies instead of selecting them.

On Playstation:

Dead body/loot box

  • Press X so move something from right to left (or vice versa)
    *Press square to take all loot and close the menu


  • Press X to select something for a fast-use-slot
  • Press square to drop something

So… accidents happen