FMTEL Assignments not tracking

Hey all. First time using FMTEL so not sure this is a bug or just me. I go into the FMTEL computer and see the weekly assignment as per the image below. I go play for an hour or two and go back to the FMTEL station and the status is the same. No progression. I have killed about 40 ticks between screenshots so… Is it me or the game? Thanks much in advance.

2 Likes

Was there an assignment to kill x amount of tics?

Otherwise I think the symbols only represent your progress towards the weekly goal: you are currently at “tick-level“ (as am I)

1 Like

Like @ObligatedRug050 said, the three machine symbols just represent how close you are to completing the weekly assignment.

In this new assignment system, daily assignments award Resistance Points which is what you use to progress through the week’s rewards. Right now you have 2 points so you are on the Tick level (basically bronze) and you’re getting close to unlocking the Tick Reward Package (whatever that is). Then you’ll be on Hunter level (silver) and then Tank level (gold).

Or at least that’s what it seems like so far.

This weeks weekly assignment has nothing to do with ticks but rather destroying 25 runners, it was just mistakingly marked as a daily assignment when assignments were put back online on Wednesday.
Also the Tick, Hunter and Tank stuff are just rewards, not assignments. Every time you complete an assignment, youll be rewarded 1,2 or 3 resistance points depending on the difficulty of the assignment. Once youve collected the required amount for 1 stage, youll get the rewards in your FMTEL Reward Trunk.

I check these daily and for all of last week and most of the week before it just kept saying check back later. Today I had missions, did a couple and now all I see is the Register for their FMTEl. I’m so confused by this. Why doesn’t it just show up and show what there is to do and if you’ve completed it all, ok, show me that. This seems a very convoluted system or maybe I’m just flat out not understanding it. It could be all me, but I’m not sure how?

I would say, give your game a restart and it should say if you got given the resistance points from the assignments.

Well, it doesn’t matter which assignment you completed. If you complete one, you get an immediate reward to your fmtel-box and the resistance-points depending on the difficulty of the assignment.

You can see the sum of your resistance-points of the current week in the upper part of the fmtel-screen.

There is no need to log all completed assignments in a list, as they are reset every day and every week.

Checked today and did the daily assignments. Once completed, saw the other counter go up. Many thanks for the info, all.

Even though this is not the 100% correct thread but at least it’s related to the new assignments system…

Does anybody else have problems with todays 2nd assignement to “Shutdown a machine with EMP”?
So far I tried Car battery EMPs, large EMP cells, small EMP cell and EMP rounds for the M49 but all of them didn’t have any effect on the assignment. :man_shrugging:

So what’s it about ? :thinking:

2 Likes

Unfortunately, that assignment is bugged. Similar to the Base defence one.

2 Likes

I have exactly the same issue :frowning:

Seems bugged for me to (on Xbox). Tried with car battery, small EMP, and by shooting electric boxes outside buildings, nothing works

Can confirm. Just took down a tank with the Exp Klauck and shut him down twice. No go on the achievement.

When I did the assignment I’d read wrong and thought that I had to kill a machine with an EMP. Silly me. EMPs do not kill, but I forgot that. Never use those things. So I stocked up with 4 medium-sized EMP cells and went looking for runners.

So on the facebook group I wrote this:

“Hmm, mine did work. Even though the emp did not kill.
I shot off some armor first, threw a few emps. 4 in total. When the runner did not die I shot it. I didn’t saw a popup, but when I later looked in assignments tab the assignment was gone.”

1 Like

And did you get a resistance-point?

Yes.
Edit: I restarted the game and the assignment was back. So I didn’t get it either.
Ah well. Never mind.

Yup, same exact issue

same here, could not complete base defence as well

You are lucky I guess. I have tried everything. It would be helpful, like you have just done, for others to post how they managed to complete the assignment.