Game lock-ups every time before town of Boo

Hello am a 72 years old gamer. I have been playing your great game here, Generation Zero, from about Feb before we had this cov-19 came out. I bought it on steam I have had NO problems at all with this game, it’s real fun to play my grand kids roped me into buying it.

I love it until this new Dec update and along with buying this US weapons DLC. All it dose now is lockups or freezes up every time I try to fast travel or go strait walking to the town of Boo (-732.124,-1771.748)

Also I can longer now go to any other safe houses that are around Boo I even tried walking to it from the safe house that’s Ok in Broskulla (-18.359,-780.851). From this same safe house I tried walking to the Sorkeiv Bunker (-499.565,-1472.327) that is way before the town of Boo. I get half way there - you guessed it, Freezes up. I quit counting how many times I have tried to get to Boo.

I even keep backup’s of my saves because if I restart the game, sometimes I can never get to the loading screen. Am watching the 2 wheels in the lower right corner in the black loading screen just stop and the freeze is at it again. This happens even when I try fast travel to Boo.

Can you please help me and tell me what to do…

Thank you Gil

Hi Biggilspc, you should also post your PC specs, and If you were playing single player when the freezes appear, or if you were in the multiplayer with your grandsons. That way the devs have a better idea where the problem might be.

Added punctuations for better readability.


Besides what is said above, for one possible fixes: validate game files in Steam.

Perhaps the devs would like to examine your savefiles?