Gamebreaking sprinting bug (Unable to sprint)

Not seen this myself. System?

Windows 10 x64
i7-7700 HQ
GeForce GTX 1060 16Go

I had this issue 2 days ago… while fighting Lvl 4 Apo Tank, few Apo Hunters, runners… etc :crazy_face:

Now at least I know what causes it.

The bug doesn’t reproduce systematically though. In the meantime I deactivated steam overlay, probably investigate in that area? Really just a thought I might be completely off-track

I’ve been having this bug too twice now. Glad I’m not the only one having it

1 Like

Hey @Grandaddypurple :wave:

This issue has NOT* been reproduced in-house [HOWEVER], a high priority ticket has been created for handling it.

Sorry for the inconvenience and thanks for reporting! :pray:

*EDIT - I misunderstood one of my colleagues and thought we had an in-house repro when it actually just occurred once during an internal play test (communication when working from home can be a bit tricky). At this time we are unsure how to reproduce this issue. Sorry about that! My bad.


Awesome glad to hear. Keep up the good work guys

1 Like

I havent noticed this bug, but my character has the knockdown reduction skill.
So has this skill something to do with problem? No skill or max level?

Well if I was correct and this bug is triggered by getting knocked down or dying (not 100% reproduceable), then having Steady feet will logically reduce the chances of triggering that bug. Otherwise I don’t know if the skill is mechanically involved with the bug.

This bug is seriously gamebreaking. I’ve noticed it never occurs unless I use the cykel/bicycle. After using the bicycle, it’s an random issue. It doesn’t matter what I am doing at all. I could be aiming down sights or jump or whatever. it will just randomly stop working and it’s always at the worst time. I seriously don’t even want to play the game until this is fixed.

**Platform: PC**

**Steps To Reproduce: Not entirely sure? It seems to occur after using the Cykel/bicycle** 

**Images / Videos: I believe I have a live stream video and I think it does occur in that video.** 

**Host or Client: It has occurred during both single player and multiplayer**

**Players in your game: My friend Kip/TheFancyGamer and also just by myself** 

**Specifications: CPU - i5 6500 3.2-3.8Ghz
RAM - 8GB Crucial Ballistix 2666Mhz **

Same here. Needs to be fixed ASAP!!

Hello everyone :wave: @Grandaddypurple @Ironborg @LelandHasGames @DystopianGZ @0L0

It appears I made a mistake here earlier, edited my previous comment:

TLDR; We are still looking for a way to reliably reproduce this issue.

If you who are affected could provide some additional info by answering the questions below that would be very helpful!

  • Can you reproduce this issue easily or does it just happen occasionally?
  • How do you workaround / get rid of the issue? By jumping?
  • Do you have SPRINT set to TOGGLE or HOLD in the settings menu?
  • When this occurs are you playing on your first and only character, or does this occur on your second, third or fourth character? IF you are not playing on your first character, is your first, or any of the other characters over-encumbered (Carrying too much to be able to sprint)?
  • What skills do you have enabled on your character?
  • IF this issue occurs for you when ADS (Aiming), what weapons are you using?
  • IF this issue occurs for you when ADS (Aiming), what scope are you using?
  • Is there anything else that you think could be related to this issue?

Any chance that any of you guys affected by this issue are on PC and would be up for sending us a copy of your save file? It would go a long way and help a lot when it comes to identifying the root cause of the issue.

  1. Your save file can be found here: Documents\Avalanche Studios\GenerationZero\Saves
  2. Right-click the save folder (containing “savegame” and “savegame.bac”) > send to > compressed (zipped) folder
  3. Go to (No account required)
  4. Click the “…” button and select “get transfer link”
  5. Add/attach the .zip archive with the save file(s)
  6. Upload and copy the link
  7. Send me a DM here on the forum and include the link from wetransfer

Sorry for the inconvenience, and thanks for reporting! :pray:

Hello @SR_knivspark

I am currently going through the Alpine Unrest DLC, I have not had this bug since I reached Himfjäll (it’s not the only bug that dissapears when playing the DLC). However, I coincidently changed my hotkeys for the Steam Overlay at the same time, so I will change it back to default and investigate that before making conclusions. I will come back to you, bullet point per bullet point, as soon as I’m done investigating on my end

1 Like

I had it only once, and no matter how hard I tried I wasn’t able to reproduce it. Especially that right afer my encounter with this bug I’ve unlocked the “Steady feet” skill.

While in combat the best way to run again was to release all buttons (arrows, shift) and press them again. Jumping sometimes worked.
After the combat has ended I simply restarted the game just to be safe.


This happened on my 3rd character. Non are over-encumbered… except for 4th, which couldn’t move with empty inventory.

X-AG4 with 5* 4-8x Scope
X-Kpist with 5* 2x Red Dot

I got it in combination with this bug:

Also I think that this happened after a rather long session (2h+).

I’ll send my save files in a few minutes.

1 Like

I’ve been trying to reproduce it since my last answer, however that was unsuccesful (I came back to the main island in the meantime). However, I used to experience it at least once a day until I reached Himfjäll, where the bug dissapeared. It seems to be view-related (when you switch to 3rd person view, e.g dying, being knocked out, riding bike).

Either letting go of all the keys (would fix it ~75% of the time), or jumping (more reliable for me). After that, sprinting would break again after aiming, reloading, or swapping weapons / items. The only way to completely fix it was to relaunch the game


This happens on my one and only character

4* HP5
5* AG5
4* and 5* AI-76
All no scope (I never use scopes on automatic rifles). I’m 100% sure the bug triggered while using these, however it might also have been triggered while using 4* PVG90 with 5* 8x16 sniper scope

Same as @0L0, but ALSO, changing hotkey for sprinting will break sprinting (same effect basically)

Here :

Thanks a lot guys, hope you’ll get to the bottom of this

1 Like

Hello @SR_knivspark,

Here is the information you requested for the sprint bug, I will answer everything to the best of my ability and send you my PC save file.

This issue happens occasionally. Not sure what exactly causes it, but it appears to be game session related as in some game sessions it just does not exist and in other game sessions on the same day the issue exists. As to what causes the issue: getting off a bike, switching weapons, aiming down sights, switching to throwables/healing items, etc. Any sort of interaction that can happen while the sprint key is pressed seems to be the culprit.

Best workaround is to jump. It is the simplest and easiest way to resolve the issue. Stopping all movement and interaction for a second works as well (effectively resets player movement is my guess).

Sprint is set to HOLD.

This happens on my first save, I have not tested weather it is exclusive to my first save only. As of writing this my current game session is not encountering this issue so I will be sure to switch characters if it comes back. Just a side mention: this would not be the first time that a bug is game session specific. Every once in a while I get an audio bug where footsteps and reloading audio never play. The only way to fix this issue is to relaunch the game.

I have various skills active including a single point in stamina recharge, stamina amount, sprint speed, and carry weight.

Aiming down sights for any weapons does this, though it appears to happen more so with weapons with an optic attached.

Any optic will cause this issue regardless of the weapon or optic type.

As I stated before under weather this issue is character specific, I think this bug is specific to the current game session. Returning to the main menu does not resolve the issue and restarting the game entirely works sometimes. For the past week that I have been playing this game I had not encountered this bug until today during my third game session of the day (I take multiple breaks while playing).

I hope this information helps, I will be DMing my save file.

1 Like

Just ran into no running bug on ps4

Thanks for the additional info and save files :floppy_disk: much appreciated!

Now, this issue is proving to be a bit tricky to reproduce and we have yet to find a reliable instant method of reproducing it, but we’ll keep investigating :mag:

Thank you for your time and patience! :pray:

Had it yesterday, after being knocked down multiple times by a lvl 4 Proto Tank concussion pulse (I also died a couple of times during that fight). Same character and weapons as described above.

After that I also had this bug:

Did you happen to be over encumbered at one point during that same game session? Even if you weren’t when the bug happened?