Host disconnected message when playing SP & MP

Platform: PC

Description: I was playing rather comfortably today when suddenly my game stopped… I was certain that it was a crash, but the tape reels kept spinning and I was kicked to main menu with standard host disconnection message… I WAS THE HOST!

Steps To Reproduce: Don’t know. Maybe some random :poop:

Host or Client: Host, game set to invite only.

Players in your game: 1

Specifications: i5 4670K, 16G RAM, GTX 1070


Something going on?

Got this 4 times this evening after 5 to 30 minutes then I wasn’t in a mood to play anymore.

Can confirm it.

Today i got booted to Main Menu 3x times with the very same error while playing in my SP game.

1st time: I was heading from Angeras church (South Coast) to Bockhyttan town (Mountains). At half-way there, i got “disconnected”.

2nd time: I was at Bockhyttan town, fighting machines. I already took out 3x mil harvs and 2x other mil harvs came from SE to Bockhyttan town. I was able to take 1st one out and while engaging 2nd one, i got booted to main menu.

3rd time: I was at Hjalmars Stuga safehouse (Mountains), fighting mil runners. In the middle of the fight, i again got booted to the main menu with disconnect error.

1 Like

I got the same experience. :pensive:
PS: This should be moved to “Bug reports”.

1 Like

I am having the same problem. Played today for the first time in a while, trying to hunt rivals. Keep getting the above message. Fourth time in about two hours. Same as 0L0 on settings with only difference being my processor which is an i5 2300.

i had a similar issue when i used microsoft onedrive , it became full and took over my documents folder. dont know if this is of any help, but worth a check.

I don’t use Onedrive, so it’s unlikely for me. :thinking:

I don’t have Onedrive either but i do have Intel build (i5-6600K). Though, i don’t think the issue would be with hardware or with Intel builds specifically.

1 Like

Maybe it’s a Steam issue?

I don’t think so. Moreover since when you happen to loose connection with Steam (or your internet connection), game prompts you with pop-up message along the lines of:“Connection to Steam is lost. Any multiplayer is disabled.”.
But that doesn’t boot you back into the main menu. Instead, you can continue playing your game, be it SP or even MP. Though, when you’re in MP and Steam/net connection loss happens, everyone else disappears while you’re left in the Host’s world with Host’s mission progress (if you’re Client).

Can confirm this. Occurrence, once a day or in gaming session.

Platform: PC
Host or Client: Host, game set to invite only.
Players in your game: 1

Buuuut… I’m playing solo on invite only… so… I left?

@Oddball_E8 ran into this same issue.

Topics merged.


Platform: PC

Description: Playing through in single player, continuing a game I have played multiple times since game launched, the game has on several occasions suddenly stopped and returned to main menu with message “The multiplayer session has been terminated because the host has disconnected.”
I am surely the host if playing single player and no other players are on the map

Steps To Reproduce: This has happened randomly 3 times during the past 6 hours, I cannot give a way to replicate

**Images / Videos:Generation%20Zero%2025_04_2020%2018_48_58 **

Host or Client: as far as I am aware I am the host

Players in your game: None except for me

Specifications: Operating System: Windows 10 Pro 64-bit, CPU: Intel Core i7 3770K @ 3.50GHz, RAM: 32.0GB Dual-Channel DDR3 @ 800MHz (9-9-9-24), Motherboard: Gigabyte Technology Co. Ltd. Z77-DS3H (Intel Core i7-3770K CPU @ 3.50GHz), Graphics: 4095MB NVIDIA GeForce GTX 1070 Ti (ZOTAC International)

I love the new update, much better inventory system

Merged topics about same issue.


1 Like

I just got this 2 times, about 2 minutes apart. I exited the game and just as I did that Steam self updater asked if I want to install the new version.

Could this be the issue?

I just came out of a good one hour solo play session, and this happened to me twice. It’s not the end of the world, and I’d much rather take a disconnect than a crash but I can’t help but wonder if it’s GZ, or a Steam issue :thinking:

I think no matter how you twist it, it’s a GZ issue, since I haven’t seen other games disconnect entirely in a similar way. Maybe it’s a GZ issue because of Steam, but a GZ issue nonetheless.
However, sometimes other games come up with a warning that it has disconnected from steam, and for instance sync isn’t available. But that should under no circumstances terminate the current session! :sunglasses:

1 Like

Dear Sirs.
I know there are some threads already open for this but NONE have been solved, nor any tip has been given: while playing solo or starting a coop game, disconnection pop up window appears in seconds; you close it and continue playing if solo. If already started as coop, you cannot open doors or so and, of course, the other players are dissappeared.
I have already contacted Steam for this but I really do believe this matter is a GZ problem.
As there is no way to solve it or contact anyone to do so, I have to refresh this known issue to see if there is a chance to enjoy this game coop instead of playing solo all the time.
This game is good as is, apart from bugs. So no need to work on skins or customization: focus on bugs because once a player leaves the game, it’s difficult to recover it.

Merged threads about the same topic, and adjusted topic title to reflect the issue.