Mouse working in menu but not in-game

new-issue

#183

I feel like it’s going to be something really simple, like as if in the back of my mind I kind of know what it is bit can’t work it out. I have vague memories of having a very similar problem in another game but I might be imagining it. I know one of the just cause games had a similar issue because the look speed setting kept resetting itself to 0 but we don’t have access to that setting.


#184

Obviously we would all like to play the game. It is why we all signed up for the beta really. You have to understand however that signing up for a beta is not just to play a game. They do it to promote the game slightly but also to have the game played on various different systems and more for the bug finding aspect rather then letting people just play the game. If you do read up one of the DEVS has already noted that they are looking into it and that they will possibly look into a future beta testing period also if they can find fixes to a lot of the bugs.


#185

Exactly if anything we’ve fulfilled our purpose as beta testers by NOT being able to play. Hopefully this will get fixed and by the time it comes to us paying for the game we won’t have this issue at all.


#186

not sure if this is any use but i have noticed that if you pause the game and note the location of the mouse pointer then unpause the game (at which point the mouse pointer should be locked in position) and move the mouse pointer as if you were trying to aim and then pause it again the pointer moves as if the menu overlay still has control of the mouse rather than the game

so its not that the mouse isnt working but its not doing the correct task


#187

I think someone stated this above already or on the steam discussion forums but idk if they tried with a controller or mouse, I have the same problem not being able to turn. I manage to watch a youtube video so I could try and navigate without turning. I manage to grab the flash light and prone and get the hand gun in the other room. afterwards I notice if i keep tapping left trigger to go to iron sights my character would slowly I mean very slowly turn to the right and downwards.

After doing that i decided to leave the house I ran and jump in the water so my character would die or restart so I could see if would reset the camera instead i respawn in the house right next to the binoculars. I dont know if you can zoom in and out with them but i notice when i press left trigger the character would pull the binoculars to his face and then like a second or 2 later it would automatically zoom in again to like a second zoom in level and I could not control how far the character zoom.

So maybe it could as far as the turning goes possibly for some computers the deadzone is being set to something terrible I know battlefield 3 or 4 had this problem on pc at a point and time. Hopefully this information gives a little bit of help for the devs towards where to look at in the code.


#188

I feel for all of you that have this issue, however, although it seems like this issue is wide spread it really isn’t, consider this, if we have a 50/50 split on Xbox and PC players we have 500 thousand PC users in the beta, this thread has 185 replies, in the effort to be fair, let’s make the number 400 (more than double), that is 0.08% of people with this issue.
0.08% of people having this issue means it will be very hard for developers to find a fix, especially given the time frame of just 4 days. As Graham has already said, he will go and confirm whether another beta test will come around. All that can be asked of you at this stage is that you can be patient :slight_smile:

Thanks all and I sincerely hope you guys get to play the game soon! :slight_smile:


#189

rip me and all my friends have this issue :frowning:


#190

Yeah sure mate 0,08%

First of all there are “only” 185 replies, currently 187, making this the most reported bug on this forum. There are also a lot of people who have read the topic and didn’t feel the need to reply because it was already reported and there was nothing to add. The topic has 1,4k views, I don’t know if these are unique views but the number of people who have viewed this thread is at least 300-1400.

Now we don’t know if guests are counted in the number of views, but if they aren’t the number might vary between 400-2500 people. I for example only created an account to give away my second beta key. I already watch this thread before.

Then there are the people who haven’t even looked at this thread, this can have following reasons: They were not that interested in the game and will wait for the next beta or the full release or more likely they haven’t found this thread. If you search on google something like Generation Zero mouse not working or something similar you will not find any threads on this forum concerning this issue. This is a huge factor in the number of reported bugs. The number of people with this problem is at least double, triple or mayby even ten times bigger than the number of views on this forum.

You are stating that there are 500.000 pc players in the beta, but are these the keys given away or the players who have installed and played the game? If those 500.000 players are the number of keys given away you have to take into consideration the number of keys lost due to:

  • people using multiple e-mail addresses to gain a higher chance to receive a beta key
  • people not having read their e-mail, or the mail went into the spam box
  • people who have no interest, are to busy or whatever

This last point will affect the % of players with this problem hugely. It won’t however affect the number of players dealing with this problem, because those numbers are calculated/estimated from the number of views and replies.

So please, don’t try to make the problem appear smaller if you can’t fix it right now.

We are waiting for the solution and if it will not come in this beta we will most likely participate in another one. We understand that the problem might not be that easy to fix and the devs might need more time than four days.


#191

Ok those are very fair points I failed to take into consideration, as such I agree the number I stated (0.08%) is quite an amount lower than that of what the true number would be.

Don’t get me wrong, this issue is a terrible one and I am not trying to downplay it at all (Something I should have mentioned previously), however, my point was to create emphasis on how difficult this issue is to not only recreate and troubleshoot, but also to fix. The developers will be hard at work, but with an occurrence rate as low as what the issue will have, it will take the team much longer than 4 days to fix, especially considering a comment I read earlier which stated that someone had the issue on only one of two identical machines which then adds to the complexity of the issue as there still doesn’t seem to be a common factor in this other than the symptoms.

Thank you for bringing the error I made up and letting me know! :smiley:


#192

@Crytical @kneut

This issue is being worked on heavily by the dev team. They’ve somewhat narrowed it down (Or at least have a good lead) to perhaps being older CPU’s. That is the only information I have to really put anyone at “ease”.

Its not much, and the bug is a real head scratcher for the whole team.


#193

it’s not older CPU’s, i have a 7th gen i3 and still can’t use my mouse.


#194

the “Perhaps” there is to state that it might not be the case for everyone, but the majority that have provided system specs appear to have older CPU’s. And this is also just the latest information that I have and its already 3days old so.


#195

the beta is ending and no bugfix X(


#196

Well im pretty sure those of us who cant play will most likely be asked to see if the problem has been rectified with extended testing, i might be wrong but it makes sense


#197

I want to play this game so much :pensive:


#198

1 like = quicker glitch fix :joy:


#199

Same issue here

PC:
Pentium G4560
GTX 1050ti
8GB RAM
Windows 10 Pro
Keyboard/Mouse Logitech k120/m110


#200

As someone that has manipulated game coding for a while (from the days of HalfLife), this seems more likely to due with certain mouse drivers since it’s a “mouse look” function during game play. The menu function operation coding tend to differ from actual game play coding. The “older CPU” idea wouldn’t be far off as this would associate with certain mouse drivers. However, it would be interesting to know if the more common occurrence would be related to anyone using non-basic mouse setup. For instance, I use a Viotek keyboard+mouse setup and I have drivers for this equipment. These drivers and software may not be “in-game mouse friendly.”

In a past beta testing I did, there was a report that the mouse drivers for the PC and the software for the keyboard+mouse equipment created a in-game conflict. Never heard anything beyond the initial report, but it has been know to happen.

Moreover, that’s the entire point of Beta testing. We’re not here to “play a new game.” We’re here to help the DEV’s fix the issues at the beginning. Some of us get solid game play while others can’t get past a menu bug. It happens, so let’s do our part and contribute what we can.

DEV’s - I salute your hard work. Keep it up. :+1::+1::+1:


I have problems with the mouse, and i like this game
#201

Hey there guys and also devs,
I also have the same problem. Any of my mice oder gaming devices (wired, wireless, programmed, steam controller or also X360 gamepad) work. I can’t look around. Walking, sprinting, jumping works flawless.


#202

I have the problem aswell me and my dad cant play i hope its gonna be fixed am soo hyped for this game :)!!