Problems with custom keybinds on PC

Thanks for the note on having it looked into, just to be clear, ALL commands should be listed in the key bind menu, any control command in the game should be able to be changed to something else, either on keyboard OR controller. This includes in menus and during the game.

Ghehe, same here. (Z = left V = Right X = Back C = Crouch Alt = Prone Space = Jump)

Very annoing and game breaking for me (z is my left for all fps games since straffe left was invented) ; i also have my razer chroma set up this way.

+1 for this one. ty for looking into it!

Hello, GZ folks! Apologies if this is already covered in another topic… if it is, my search skills are weak!

I’d like to make a feature request: Allow the mouse wheel (up & down) to be changed in the keybindings.

Specifically, here is what I want to be able to do:

KEEP mouse wheel up & down for my zoom in & out on scopes/binocs
REMOVE mouse wheel up & down from switching through weapons/items

I do my weapon switching by hitting 1 or 2 to switch between primary weapons, and I use other buttons on my mouse (many buttons) to bring up medkits, binocs, etc. once they are assigned to 4-7 item slots.

I would simply like the option to unbind my mouse wheel up/down from weapon/item switch. I’m not saying to take it away from everyone! :slight_smile:

I tried rebinding zoom in & out just to see if it would clear anything from the weapon switcher, and… it didn’t recognize when I was rolling my mouse wheel up or down, so I couldn’t bind something else to mouse wheel up or down. Because of this, once I changed it, the only way I was able to fix it was to reset ALL my controls and then customize them again. It seems when trying to change zoom in/out, it doesn’t recognize that you are moving your mouse wheel.

Good gaming!

Same feature request topics merged.


Platform: PC, Steam

Could be pretty confusing if you have more side buttons. Almost every mouse have side buttons this day. [[PC] Extra mouse buttons don't work (RESOLVED IN UPDATE 2019-03-27)](Another post that describes that the side buttons didn´t work but this is now fixed.)
It works but is confusing when binding keys.
Steps To Reproduce:
Bind your side mouse buttons to any slot.

Host or Client: Nope.

Players in your game: None - 4

Specifications: This is not a computer related problem.

Same content topics merged.


There are still some PC key bind bugs remaining since launch (2 years ago), and with the new base building it got a bit worse.

People who are using for instance the ‘F’ or the ‘B’ key for movement or otherwise, will have problems building their bases since the base building keys are fixed and not configurable.

This is also (as earlier mentioned) a problem when scoping (the F key wont work) or when riding bicycles (Bicycles only use default wasd, non configurable).

I’m just curious if you are ever going to address this/these issue(s)?

I’ve merged this with the main topic on the issue, and I’m going to poke at the devs to see if they can up their priority on it. Being able to fully customize your key settings is something that should be standard in a modern game.


Please adjust keybinding to clear a key that is in use instead of telling me its already assigned to a key.

Also, after rebinding my keys because I don’t use WASD, make it so that E is not the default accept key and assign that accept what is bound to what ever interact key is used so it doesn’t break the game.

Same issue I’m also having while aiming. I can no longer move forward because I use ESDF for movement.

Same content topics merged.


Same here, do neither know why this isnt changed yet nor why so many keys were hardcoded.
E.g. “Take All” is set to R. But changing the only R command (reload) in the settings doesnt help.
I’m using autohotkey to change everything the way I want. This is so ninties…

1 Like

Platform: PC

Description: If move forward is bound to E, then cannot move forward while aiming down sights or using binoculars.

Steps To Reproduce: Remap move forward to E. Equip a weapon or binoculars and zoom or aim down sights. Attempt to walk forward.

Images / Videos: Not relevant

Host or Client: Not relevant

Players in your game: Not relevant

Specifications: Not relevant

Same problem here, and I can’t understand why so many different topics are being merged. Not being able to move when using ESDF for movement and having sights or binoculars up is not a feature request, it’s a bug, plain and simple.

As a programmer and a 150 wpm typist, obviously I’m going to use ESDF. Any touch typist is going to want to put their fingers on the home keys when using a keyboard, you get more keys that way.

How has this been open for so long? I just bought this game an hour ago based on Splitsie’s youtube series. Thought it looked great and was worth supporting. But I absolutely will be going for a refund. This kind of obvious to find, easy to fix bug being open this long after being reported is inexcusable.


Another lefty here complaining about keybinds that havent been fixed in years. I dont ride the bike so that doesnt bother me, but not being able to rebind sprint to the right side where i use teh arrow keys to walk is annoying and makes it far harder to run around and kite bots.

1 Like

What key on keyboard would you put sprint on if you could?

Recon update changed some things and mapped bicycle controls directly to be the same as the on foot movement controls. OK, that’s fine, as long as I didn’t WANT them on different keys for any reason, but that’s neither here nor there I suppose. Problem is, you can’t dismount the bicycle with the key you have set in the keybinds list, it’s hard coded to the space bar. So even though you set it to something, it gets ignored, use space bar and like it I guess.

Also, hand brake is nowhere to be found and the same for pulling a wheelie, not on the list at all, but they never were, so not sure why I’d expect that. Thing is, even my workaround fix doesn’t work, the commands have been removed from keyboard use entirely. Nice job.

Yeah, I just tried out the bike and same issue - RMB in my case. Hitting enter got me off the bike (I use enter as a default interaction button).

Ah, OK, thanks for the info. Just another thing that’s messed up with keybinds.

OK still the same deal in Dark Skies, no fix. Dismount vehicle is still hard coded to the interaction key you have set and whatever you have set to dismount in the keybinds list is ignored. Not the best user experience if they are expecting the dismount key to be one thing and it’s something else. Also no keybind at all for handbrake or wheelie, though you can use a custom file to get handbrake back, there’s no way to get wheelie function back on keyboard, it only works on a controller.

Keybinding is broke;The game is unplayable for me. ; a fix would be much appreciated.