Unable to play multiplayer with friend - "Failure To Join - Host Is No Longer Present" error message shown

Hey @hellmatic :wave:

I moved your report here as I suspect this issue (or something really similar) is what your friend is experiencing.

Please ask your friend to check out this forum thread, especially the suggested potential workaround and see if that helps;

We have a ticket for this issue, however, at this time we can’t provide have an estimate on when we’ll have a fix for this.

Sorry for the inconvenience and thanks for reporting! :pray:

This has been an issue since 2020. My friends and I would not have bought this game if there was a problem with the multiplayer since that is the only reason we bought it. We all love what it has to offer but if you guys can’t fix something like joining a session in progress, we may as well refund our purchase.

1 Like

hi this problem is back i play this game for a long time now i have friend that cant join i can invit what i want
but its not working

The game cant connect to host.
Error message given “The host you are trying to join is no lomger available”
This started a few days back out of the blue.

We have tried on both xbox one and series s consoles.
WiFi and wired, switching hosts with no luck.
I have seen that others are having the same issues but couldnt find anything here.

Hope this will be resolved soon.

Hi there!
Im not using xbox myself, but im curious, are you trying to connect to a public game or a specific friend?
If one, could you try the other and see if its the same on both ways of connecting?

From my perspective this could be a network issue, but thats hard to test… Its not like average joe has dual internet uplinks… :stuck_out_tongue:
But it might be worth the effort to check your network settings and possibly checking with your ISP if there are ports blocked.

Here´s the ports needed (according to 3rd party website)
Generation Zero - Xbox One
TCP: 3074
UDP: 88,500,3074,3544,4500

Hey @baghera41 :wave:

Sorry to hear that you are experiencing this issue. As you can see in this thread which I moved your topic to you are not alone in this. Unfortunately we have yet to identify what causes this, but we have a ticket for tracking and investigating the issue.

In the meantime I recommend trying this potential workaround;

Here are some questions that could help us in our investigation, if you can find the time please consider answering these, thanks!

  1. What type of network are you on? Is it a private home network or is it e.g. a public college campus network? e.g. Is there any chance your router has restrictive settings and e.g. has ports that aren’t open?
  2. Have you tried playing on a different network? IF yes did it work?
  3. If you do a network test on your console (via the console settings menu) is there anything that looks off or is the network test showing good/green results? (IF there is something that looks off please consider providing a screenshot)
  4. Do you have similar problems with other games or is it just GenZ?
  5. When did the issue start occurring? Have you been able to play previously?
  6. Does this occur 100% of the time (that you can’t join) or does it occasionally work?

Again, sorry for the inconvenience, and thanks for reporting!

1 Like

You may need to check your NAT setting in your router/modem -set it to “open”. It directly relates to multiplayer setup. I had to research this because I had some speed issues in which Comcast remotely reset some configuration in my personal router. There is info on xbox.com:Xbox Support

1 Like

@liggisten , tried all above already, nothin helps :frowning:

I am sure its not an issue with the network since several players on xbox is having the same problem.

1 Like

Hi and thanks for the reply.

  1. Type of network: private, home-network.

  2. Yes, it did not help.

  3. I did network test using my fiber connection. Under NAT-TYPE it shows that xbox cannot get IP from Teredo. I am using IPv4.
    I have no other issues with other games.
    NAT-typa at router side is set to open.

  4. No, no other issues with other games.

  5. This occured last week, I think…,I have been able to play without issues a long time before that.

  6. Yes, this happens 100% of the times joining or hosting does not make a difference.

I have tried all the “Microsoft-solutions”; powercycling, reset router etc. to no avail.

Tried joining both open games (cant find any) and specicic friends.

1 Like

Thanks for the additional information, @baghera41! Much appreciated. It has been added to the ticket as part of the investigation.

Sadly we are at a bit of a loss as what to do right now for those of you experiencing this that can’t get around it via e.g. the power-cycling workaround…

Something that would be interesting is for you/your friend to try this while on a completely different network and see if the issue still occurs, but I realize that might not be a particularly attractive alternative and a bit of a pain to deal with. Maybe our game has problems with certain types of networks/setups? :thinking:

As we are having problems with XBOX in particular right now it’s also not entirely clear when we’ll roll out an update (We’ll share news on this on our official channels when we know more). If we are lucky the next patch has a positive effect in regards to this issue, however, even if we do roll out an update, at this time there is no guarantee it’ll fix it, as we have yet to find the underlying issue and root cause of this. It is really strange how it works and then all of a sudden stops working without any clear indication or reason as to why :thinking:

I’ll make sure to post any updates on regards to this issue here in this thread.

We understand this must be very frustrating and know that we are sorry for the inconvenience :pray:

1 Like

Platform: PS4
Description: When try to join a friends session, the error message that the host is no longer available is shown.
Steps To Reproduce: Just accept the invite or try to join via user profile. we also tried to change host/client and switched from “only invite” to “anybody”.
Images / Videos: yes, screenshot on PS4
Host or Client: Tried both ways, I tried to host a session and also I tried to join my friends session.
Players in your game: None but me, others weren’t able to join due to this error.
Specifications: PS4 with the latest system update.

Platform: PS4/PS5

Description: unable to play with invited friend

Steps To Reproduce:

Images / Videos:

Host or Client: both tried

**Players in your game:**2

Specifications:

Come on we have 2021 and we are not able to meet in the game. A friend of mine has bought the game and all the dlc and me too. We can’t meet in the game. We have tried everything in this Forum. And nothing works!!!

Please solve the problem. We both have the same message that the host is no longer present!

Please answer how we can easily meet in 2021 like other games!

Thanks

Hello @SR_knivspark ,
I play on PC (Steam) and had a friend of mine from Sweden get the same so we could play together. Our experience has been poor and matches much of the above with a number of bizarre additions.

If I host the game, he can connect in, but if he interacts with any containers he will glitch and no longer appear to move (from my perspective). At that point he is in the game as a ghost. He can move about, can not open doors or containes and robots do not attack him. He doesn’t show up on the map, I can’t see him even if I’m in the same room as him and he isn’t in the team list.

Both of us independently can join random games through “Find a game”. If I attempt to connect to his game, either through an invite (through Steam) or by picking Join game (again through Steam), I always get the Host not Present error message.

I’m based in the US on the East coast, so I suspect the additional network latency is further hindering things.
Of the dozens of MMORPGs I’ve played and other multi-player titles, this is the first one with this pattern. I have a VPN connection and the results for me are the same whether or not it is active. I’m having my friend get a VPN also, so we can bypass possible blocking at the level of his ISP or router.

The “power cycle” option seems to not apply, as I’ve not had any changes in behavior following a reboot.

It is interesting to note that another in-game friend is able to join my session with no apparent issues, though I suspect they are at least on the same continent with me.
Let me know if there are any troubleshooting steps I can take to help you guys.

-Doermank

Hi @Doermank :wave:

Thanks for the detailed report, much appreciated!

I find this (Above) especially interesting and will make sure to add this to our ticket for tracking this issue so that this information can be taken into account in the investigation.

Based on this information (above) I would be very curious to hear if others experiencing this issue knows if the person you are trying to play with is geographically far away from you / on another continent and if it’s possible that there is substantial network latency between the two of you. If you are experiencing this issue and can provide this type of information in a comment below that would be great, thanks!

Thanks for already having tested disabling/enabling your VPN, and please let us know in this thread how this behaves after your friend has gotten a VPN as well and you’ve tried to play together again.

Sorry for the inconvenience and thanks again for reporting! :pray:

1 Like

Based on some unique aspects of his behavior I suspect a port blocking/failure to forward type issue. This was the primary reason I’ve suggested to him that he make use of a VPN. I personally use NordVPN as it has very low latency and works with all of my games. I’ve recommended the same for him. BTW I am also a software engineer, enterprise architect and cloud engineer. I’ve got a deep understanding of network technologies and how application level protocol decisions can impact performance, scalability, security and reliability. I’d be happy to help with your debugging process in any way that makes sense, up to and including capturing network interactions with wireshark. Good luck with your debugging process!

2 Likes

That’s interesting @Doermank! I really appreciate you sharing your expertise and being so helpful.

I have forwarded your mentioned suspicion (port blocking/failure to forward type issue) to the team for discussion and how to best proceed.

In the meantime, as we have been unable to reproduce the issue internally the network capturing via wireshark does sound like it could be worth a shot and give us some more insight into what is happening. Let’s discuss in DM’s how to handle that (I will send you a message).

Thanks again! :pray:

I don’t know if this will help or not, but NordVPN does not support port forwarding.

im here new to the game having this problem. i play with 2 other people. me and 1 person cant join each others worlds and cannot accept any invites from each other. but we can both join our other friends world. the only thing is when we join w ecant see each other at all. what is going on i spent $30 on this game and getting upset.

Hello!
Me and my girlfriend play, or rather we want to play together in a wonderful game, which is Generation zero. Unfortunately, there are problems with joining, as above, but it succeeds after a few times. The worst thing is that every 10 minutes he throws it away and we have to try, reconnect. When you finally fix this error. You are wasting the potential of the game.

Same issue on Xbox. Fail to join multiplayer session, or the session is full. Tried everything to fix. No luck connecting.