Weapons not changing, not reloading


it repeated couple times in different places:
I was staying in one house for quite time , because there were lots of robots outside and all were attacking house I was in. Many robots produced low game FPS and while trying to shoot them (why door glass is bulletproof? ) through windows - my Automatgevär 4 all bullets were gone - I had 0 bullets for my Automatgevär 4 in inventory. Changed hand to secondary weapon and kept shooting till had couple bullets left , tried to change second slot weapon to shotgun , when I did , it swapped with very big delay, then tried to change first slot Automatgevär 4 to another rifle , but then it started act weird - change do not responded and Automatgevär 4 remained on that slot for a while, then after many tries it slot disappeared as I never had weapon in that slot. Changing bullet type also was struggling - with very big delay. Only running through horde with no guns to another house solved this issue, all slots and weapons reappeared and started working again.

Steps To Reproduce:
Lots of enemies attacking me while I sit in house. Getting quite low FPS.
Weapons almost empty, near to 0 bullets or already empty.
Trying to change to another weapon any of slots.

Host or Client:
Host. Playing alone on my own.

Players in your game:

issue started after latest April update (not faced before with this issue)

1 Like

Very similar issue for me last night. No manual gun reload, had to wait for the clip to be spent until reload. No access to sidearm, and very very iffy response from gun after spent clip reload.

Then on reload back into the game, no inventory slots at all. Had to drop everything and pick it back up for it to save again into quick slot.

PS4, when I try to change weapons it will take one out but not replace it with the weapon I chose. Happens repeatedly in heavy combat situations, most noticeably when a robot is stuck in a continuous firing bug. When I get away from the location it resolves also it happened once that when I killed the firing glitch robot ( doggy ) I think, it resolved itself. I was also playing solo.

Guess it’s the same issue as described here:

I hope there’s a fix for that any time soon - it’s been around long enough.

Both issues have occured more frequently recently for my part.
Always in large fights, but that’s all I can put my finger on. Seems almost to be happening randomly.
The no manual reload bug usually repairs itself by looting a mech if you get the chance to do so.
Swap weapon to slot bug usually takes some time before it resolves itself in mysterious ways…
These are the bugs I really want to get rid of right now on PS4.

Happened to me a couple of nights ago as well. (PS4) The Pansarvärnsgevär 90 wouldn’t shoot and I couldn’t reequip the sidearm slot until i quit to main menu and resumed the game.

I also had my first hard crash the same night.
I was walking along the roadside close to Kaptensvillan when the game froze briefly and then terminated.

Last night I also had problems with stashing one of my hand guns to the Plundra. It just wouldn’t be put away, but after moving other objects back and forth from the Plundra, it suddenly worked again.

The walking crash happened to me as well a week ago.
After a fight at Farela I was walking towards a destroyed FNIX tank and suddenly out of nowhere the game froze and crashed…

It’s strange how these bugs suddenly appears to different players when there hasn’t been an update for half a year…

Strange indeed…
And lately, I’ve been around Norrmyra a lot, there have been a tank supposedly inside the mountain of the bunker facility. Couldn’t see it with my OPV, but the sound of it’s presence was really strong. Never happened before. Yesterday it was gone…

this bug has been around for atleast a year, encountered on both pc and ps4, sometimes then the frames drop this occurs, it fixes itself if you for example move away from some of the ”heat” from the bots…