Building Blocks Mission bug

Bulding Blocks mission bugged after I defeated the FNIX base.Mission changed to claim the control point but I cant claim it (noting spawned), so went main menu and go back in now game thinks the FNIX base still there but base isnt there and runners keeps spawning.


xbox bugs didnt happen to me.

any idea how to fix it anyting I can try?

Did you try to restart the game?
Maybe there is just some kind of delay.
Otherwise it seems to be locked, if you cannot claim the base but the mission is still shown as finished.
Then you’ll have to wait for a hotfix.

Can you additionally provide a screenshot of your log and map that show the mission and the location?

I restarted the game base respawn kinda generators didnt repawn so I cant destory the tower

1 Like

This should be a good hint for the devs.
The objective for the generators is finished, but the generators aren’t there any more. Without generators you cannot finish the mission, because the shield is still active.
@Zesiir could you forward this?

1 Like

The FINX base didnt even spawn only the generators did and nothing else, could activate capture control point but nothing happens

1 Like

So I started this mission, The mission “Good News” was availiable, but had not been completed, i decided to do this mission instead.

Came past the destroyed house with the soldiers and was informed that I have to open and destroy the shield generators. Which I did, the asked me to destroy the command centre. Which never spawned. Now I cant complete this mission, and the mission good news has dissapeared completely
All i see is this, the command centre was nver there

1 Like

Thanks for the report. Moving this to the main thread covering the issue.


same issue for me i think. did the good news side mission also disappear?

1 Like

I have exactly the same problem. Picture l looks teh same. What is interesting is that I play coop and my friends screen shows the full base!! He can watch me walking around it with guns trying to shoot me but not hitting. Would really appreciate a work around of a fix to this as it is interrupting our coop play. Thanks, Joe

1 Like


So, for those who have the problem, and play coop or have a friend that have the game, here is how mine got fixed (please note that I’m not sure it’ll work for you since i don’t really know how the bug happen in the first place) :slightly_smiling_face: :

My friend which hasn’t completed the mission invited me into his world and we did the quest. Afterwards, when going back on my world, quest did fix itself, although i had to destroy the tower again.

Hopefully it can help people and/or dev with the issue!


I co-op with a friend and initially he had the issue but I didn’t so we exited the game without attempting to complete the mission. Upon logging in the next day we both had the issue. We did not disable/destroy the generators so we see two red beams emanating into the sky from the base, and no shield generator (before the bug hit me I could see a tall device in the middle of base with radar type dishes on it). No walls, no guns either but as another poster mentioned before the bug hit me, my friend could wander into the middle of the base and I could see the turret guns blazing at him but doing no damage though in his view nothing was happening. I am on a Windows 10 PC, up to date Windows patches. Running through Steam with the latest game patches available. I had joined my friends game, though I see this if I start it on my system and run solo too. This is viewing the Sjoglimten Control Point.

My view of the base with this bug (previously I saw walls, turrets, radar dishes, etc):


PC, Steam

Unable to complete the new mission, Building Blocks. In my case, the Sjoglimten Control Point was neutralised either prior to Feb’s patch or prior to the Building Blocks mission, but either way the site now only includes 2 generators and nothing else, rendering the mission incompletable as there’s no FNIX Command Center to destroy. Not sure if there’s a correlation between issues with completing regular Base Assault missions and the Building Blocks mission, but here’s a link to that issue just in case.

Steps To Reproduce:
Neutralise Sjoglimten Control Point before Feb update (or maybe before starting Building Blocks mission). Complete the Building Block mission’s objectives up to when the player’s required to destroy the base.

Images / Videos:

Host or Client:

Players in your game:

Windows 10, Intel i7-2600K, 8GB RAM, NVidia GTX 1070

I may have completely (or partially) solved this problem! I’ve experienced this issue as well as an issue with Base Assaults being incompletable (bug report here) ever since the Feb update landed. This is how I resolved it:

  1. Start Building Blocks mission

  2. Complete all objectives up to the point where you reach the old barn and oversee the FNIX base at the Sjoglimten Control Point

Since I had neutralised this point prior to the Feb update, no base or units appeared - only 2 generators:

  1. Destroy all generators

  2. At this point the next objective is to destroy the non-existent FNIX Command Center, which obviously can’t be done. Leave and complete a base assault on any other FNIX captured control point. Destroying the FNIX Command Center also counts towards the Building Blocks objective and unlocks the next mission objective.

You can see here that I was able to successfully destroy the Sundby Camping Control Point (finally!) and have it count towards the Building Blocks mission:

And that’s it! Claim the point, build something and you’re done! Hopefully that helps anyone stuck in the same pickle and that the devs smooth this one out in the next update.

1 Like

Yes: There seems to be an Issue with the Building Block quest.
For me, I had No Issue with Old Save at level 10 player … OR … Starting a New Game completely by deleting all Old Saves and starting with a Brand-New Character … It worked both times as intendent and I was able to complete.

But many players are having problems with it not showing up at all or only partially showing up and has been reported on Steam.
So, the issue is not everyone is having the problem.

But … Starting a New complete game by deleting Old Saves file has helped several get through this quest … and … Yes, that is a Real Pain in the Butt for many … But that has worked.

Just a couple thoughts here for anyone that might be having the problem with 'Building Block quest" Until a fix has been made.

Edit Thinking … IT Could Every Well Be a Timing Problem for many that are too far along in Game for it to work properly.

yes but how do you start doing base assaults without having completed either good news or building blocks?

Another aspect of the bug, it seems. My ‘world’ has about 500+ hrs invested in it and virtually all missions complete, so I may be in a different position than yourself. Fingers crossed someone finds a workaround, otherwise we’ll have to wait for the next patch to address the issue.


I had no problem with the new mission, but because I had my base there before the new mission was added one side of my concrete walls was gone, because the command truck was moved 4 tiles.

I wanted to try that but for some all other FNIX control points are already neutralized thus not letting me advance. Is there anything I can do to fix the issue?