Corrupted Save File

I did, but the ones I found were posts from '19 and older?
I missed this one, miss, for which my apologies… :frowning:

Could very well be, miss.
Maybe the game closed incorrect for me as client?
A disturbance in the force, perhaps? (network issue)

More like a hint not to exploit the game by using the “mule” char.

For example: i’ve had GZ crashed on me on countless of times and i have very old save, yet, i have never had save file corruption since i don’t use the “mule” char.

Another thought of mine is the game files corruption on the storage drive itself. Since like we all know, nothing lasts for forever and storage drives do fail, eventually. HDDs are far more prone to file corruption than SSDs, especially at the end of their life but SSDs aren’t 100% safe either. Btw, i have my GZ on M.2 NVMe SSD (Samsung 960 Evo).

Plain SSD here, miss, on which my system sits.
Samsung 240GB.

However, what you said is plausible.
Then again, I was just barely over weight limit, so…
I only use it to actually sort things out, miss.

Unlike some, I do not exaggerate in storing on mules…
Still, yes, it could be in fact the mule.
Strange it does not happen more though, seeing I have been giving out stuff quite a bit.


Run into this issue with 240+h into the game and it’s really making me lose my mind. Tried the .bac file and it didn’t work either. Is there anything else I could do? I really love the game, but no way I’m starting all over again

Platform:
PC w/ x-box elite controller

Description:
Was playing along after defeating a couple of tanks and the controller stopped working. I figured something was wrong so using keyboard and mouse started running to a safehouse to save. Didn’t make it. The game froze and didn’t continue or crash to the desktop. I tried to bring up Task Manager but the keyboard was also frozen. I finally had to do a hard reboot to get my computer to work. After that I tried to get back into GZ but had corrupted game files, also the bak file was corrupted.

Not sure if it made any difference but Windows was/might have been updating at the same time.

Steps to reproduce:
None

Images / Videos:
None

Host or Client:
Client

Players in your game:
One

Specifications:
Processor - Intel i7 4770K @ 3.5 GHz
RAM - 8 GB
System - 64 bit
Windows 10
Graphics - GTX 980 Ti

Hello everyone :wave:

First of all I just want to say that we are very sad to see that so many are getting their save files corrupted. This is a huge bummer and know that we are doing our best to prevent this from happening.

We are currently at the point in the investigation where we need corrupted save files from users that haven’t clicked “OK” when the “corrupt save game - restoring of save file failed - do you want to delete your save” message is shown.

Clicking “OK” deletes your save and creates a new, blank save, and a save in that state unfortunately does not tell us anything. However, a save file which is in the state where you get this message on booting the game would be very useful for us in our effort to identify the issue and prevent it from happening.

IF anyone get’s this issue on PC please consider closing the game (via e.g. ALT + F4 or right-click close application on taskbar) when the message is shown instead of clicking “OK”, and then sending us a copy of your corrupted save file.

  1. Your save file can be found here: Documents\Avalanche Studios\GenerationZero\Saves
  2. Right-click the save folder (containing “savegame” and “savegame.bac”) > send to > compressed (zipped) folder
  3. Go to https://wetransfer.com/ (No account required)
  4. Click the “…” button and select “get transfer link”
  5. Add/attach the .zip archive with the save file(s)
  6. Upload and copy the link
  7. Send me a DM here on the forum and include the link from wetransfer

Sorry for the inconvenience, thank you for your patience and thanks for reporting! :pray:

3 Likes

I think the save game process should be altered to prevent this. You basically have a SPOF here.

Consider this process:

  1. Copy the current save file to .sav
  2. Verify the .sav
  3. Copy the current save file to a backup file
  4. Verify the backup file
  5. Save current progress
  6. Verify the current save file
  7. Copy the current save file to a backup file
  8. Verify the backup file

or

Implement a timestamp-based save files with limited amount of save files (10-30) and either load always the latest one.

My 2 cents, 100% frustration reduction guaranteed.

2 Likes


Yesterday everything was ok with my save file but since today when I try to open the inventory of my first character the game crashes

pls help i dont whant to lose the weapons
Kind regards seppi141

Hey @seppi141 :wave:

Thanks for the save. Using it we were able to reproduce the crash you mentioned (occurred on opening the inventory). We’ll take a look and see if we can sort this out for you.

Also, this isn’t really a corrupted save file but something else resulting in a crash, so I’m wondering if you would you be up for writing a separate bug report for this and linking it to me? That would be much appreciated!

Thanks for reporting! :pray:

…aaand it happened to me as well. Right after the Reaper was generated in the session, my game hang and I lost my save and 7 days of Halloween apparel with it :frowning:

Guys, please, would you kindly prioritize this? I love this game, but the saving mechanism is simply broken :-/

So my game totally crashed without sending any error report. Now i restart and it goes straight to New Game NOT continue… Is this common? i have been playing a long time will i have to go back and re-collect everything???

First of all:

Second - manually backup your save files after a game session. This way if a save gets corrupted then you’ll lose only few hours of gameplay.

Save file corruption after game crash or power loss is an issue known pretty much since the game launch.

Same issue topics merged.

//Mod

PC
I was playing one night and turned off the game after well yes saving than I came back on and it said my game save had corrupted and I lost my Experimental PVG, Experimental rocket launcher, Automegaver 5, Ai-76 and my Magnus with FOA Boots and a bunch of experimental clothing and stuff.

Same issue topics merged.

@PlainPlatypus look into here as well: Please send us your corrupted save files (PC)

//Mod

About 15 hours into the game, the computer froze, could only restart. Started up the game and got the question about corrupted save game. Deleted the game, as there was no other choice. Started over, which fucking sucks. Ten hours into the new game, at about the same point, computer feels laggy, mouse input is sometimes ignored, chose “Quit to desktop” as i feared another crash. Computer froze, no other choice but to restart. Start up the game again. “save game is corrupted”. Alt + F4.

  • Copied .bak to savegame, no luck.
  • Downloaded steam save, tried both savegame and .bak. No luck.

There is only one thing left to do. Leave the lowest possible review score. And then I am done with this game. So very, very done.

I feel your frustration. There are options for making backups if you care to give it another go, until the devs have sorted their own ingame backup solution.

Feel your pain buddy - this has been reported WAY back, and guess they’re still working on it.