Can equip only one main weapon after March 2020 patch [Workaround]

Platform: PC

Description: At first all was looking fine, but after tinkering in my 3 characters inventories I’ve noticed that I can only equip one main weapon. And not only one slot - ONE WEAPON.
On character 1 it’s HP5
On 2nd it’s m/49
On 3rd it’s Algstudsare

Other weapons I can equip, but not select them in any way in game.

Handguns work correctly.

Steps To Reproduce: Unequip everything and try again.

Host or Client: Host

Players in your game: 1

Specifications: i5 4670K, 16G RAM, GTX 1070

note, first screenshots were made during weapon switch - hence no weapon visible

1 Like

Same her… This is not good…

1 Like

Well… emmm… quick solution:

Drop all weapons, and pick them back up :joy:

For me no matter what weapon i put in the nr 1 slot, i cant select it in combat. Only the nr 2 and 3. :thinking:

This is dangerous according to: Watch out by dropping weapons!


Simply make a backup of your save files and proceed :wink:

1 Like

Had the same problem, and I may have a solution.
dropping my whole inventory then picking it back up again seemed to fix the problem for me at least

Hope this was of help

I have a similar but slightly worse problem: I can’t equip a main weapon at all. Only the secondary weapon slot is open (i.e. the one you can put pistols into). This is true for all weapons I’ve tested. All other slots (4-7) work just as intended.

Edit: Dropping and re-equipping a weapon seems to solve the problem for that paticular weapon

Had the very same issue where when i tried to equip other weapons i had, i couldn’t.

  • on 1st slot, i was able to equip only my 6* .50 cal and no other weapon.
  • on 2nd slot, i wasn’t able to equip any weapon.
  • on 3rd slot, i was able to equip any handgun problem free.


  1. put every weapon you have into Plundra
  2. close Plundra (just in case)
  3. open Plundra and take all your weapons out
  4. equip your weapons
1 Like

this worked for me also. BUT took an hour to re-equip all attachments to just the guns I was bringing with me. Since putting the guns in PLUNDRA now removes all attachments too. NOT a good start for this update.

1 Like

It doesn’t, despite Plundra showing like so.

At least it didn’t for me. When i pulled my weapon out, all the attachements it had were still equipped to it.

What Plundra does show, errenously, is every attachement separately, even if they are equipped to the weapon. At the same time, Plundra shows no attachements on the weapon, even if it has them.


Can only equip #1 slot, #2 and 3 show as equipped but are not…
Pushing those numbers does nothing, and dropping everything and re-equipping doesn’t help. :frowning:
Storing loot in Plundra and then re-equipping it worked for me!

I can’t equip Experimental AG 4. Rest of the guns is fine.

I cant equip Sjöqvist semi-auto, so far only weapon i have noticed. Doesnt equip on primary or secondary weapon slot.

Found other workaround
Emptying weapon slot, drop weapon and pick up, it goes to weapon slot.

The old 240 5.56 and 7.62 ammo stacks are still ‘in’ the old weapons.
It’s seems to be enough to remove the ‘old’ ammo stack to be able to re-equip weapon and tie it to new ammo.
Less crashes that way, but still I didn’t lose any weapons due to the crashing from the juggling of the weapons.

It’s almost not a bug, as the old system counted the weapon+attachments+ammo as a unit more or less, now it have to re-style the way the ‘unit’ works. (try dropping some ammo that isn’t even compatible with any equipped or carried weapon, and the equipped weapons more or less gets reset to standard vision mode, and currently used weapons gets lowered as if you just changed weapons.

But at the same time weapons in the lootbox and their attachments are tied together, but the attachments don’t show that they are tied to a weapon, so that can lead to tossing away/trading/recycling something that looked like it were a spare

We need to be able to ‘lock’ weapons, as it is right now it’s almost an invitation to accidentally recycle favorite experimental weapon, or take apart something in the box.

Hey all :wave:

A high priority ticket has been created for handling this issue.

In the meantime, those of you affected can hopefully make use of one of the following workarounds:

  • Drop your weapon(s), pick up again and re-equip
  • Drop everything in inventory, pick it all up again and re-equip

Sorry for the inconvenience and thanks for reporting! :pray:


Sounds like a similar problem that popped up awhile back where an equipped weapon couldn’t be loaded or reloaded with ammo, if you dropped said weapon then picked it back up it started working again. Wonder if it’s related, though I believe they patched that problem a few updates back.

its hard to say if its related , but the good news is that a dev has stated that it is a high priority for fixing .

ah i was having this issue earlier couldn’t swap them, thank you, hopefully they’ll have a hot fix for this out soon as well as the sights/scopes not showing what rarity they are, those are really my only complaints about the update

Hello. I have the same issue. But since I didnt see anyone saying what plattform, I just want to add that im on the PS4.

1 Like