Completing locations - All weapons


#21

Now you mentioned this plough, I know… I totally forgot to take a nice picture of the tractor with that plough still attached. Nor from the armored truck.


#22

Here are few pics that i took;

Snowplow tractor


#23

I am trying to get at the 8th weapon in Masskar Resistance Camp. I have found the cave but can’t get to the beach at the far side with the body. I’m guessing the weapon is there. Do you need to craft jumping boots to leap across the gaps in the broken walkway? Every time you fall in the water you drown and respawn on the hill above, so that is really frustrating. This is called Really Poor Level Design.


#24

I don’t think you need special shoes. I don’t have trouble getting there, however the 8th weapon is not there. There is a weapon there, but does not count for the completion of the location.
I jump via the stones to the kolom, from there I make way to the first row boat, from the boat to wooden side walk, jump the gap. You can now reach an area to find stuff, then go back to the water line and jump the stones to reach the kolom on the other side than the first time. From there jump the stones to pass the second boat on the right side, but I don’t need to jump into the boat to reach the area of interest.

Did you find a sledge hamer? For me that was the eight one.


#25

Okay thanks, if the eighth weapon is not there, I won’t bother as I drowned about 10 times trying to jump the various gaps. Its like a platform game and really shouldn’t be in a game like this. The last time I had to jump about like that was in Half-Life.

Yes, I have the sledgehammer. Thanks for your help. I’ll just have to keep looking…

Another thing that bugs the heck out of me is the game counting items from the FNIX DLC even though I don’t own it. The game’s telling me something is there and it just isn’t; that’s wrong to me. Its like a sneaky way to encourage people to buy a DLC they don’t really want.

I’m pretty sure there are bugs in the weapon counts at a few locations. At Saltholmsbro I have picked up a revolver in the woodshed and an assault rifle at the small island barricade yet the game says I’ve only found 1 of 2. I’ve scoured the entire landscape and got myself burned in the ruined building but can’t make that #2 weapon pick up number change!


#26

I know them all 8, but if I were to guess you might not have the one next to the soldier in the lookout tower with the drums next to it right in the beginning. It’s not that easy to get up there.You might not like it. Jumping again.

About not counting all weapons for completing locations, that is true, not all weapons are identified to belong to the set of weapons you need to find.


#27

Oh there’s one in that tower? Gah… well I know where it is now, thanks.


#28

Is there anybody who finished the Fnix Rising Missions and who is willing to go to Stenungsnäs Generator to verify if the generator isn’t moving. If it does move this might be a bug for me. Or might there be another way to get that weapon on the roof? I don’t think there is a parkour route though.

Edit: I got it with a field radio.


#29

Well I thought I had all locations completed but no, I have only 3 of 4 weapons from Torsberga fort. I searched and I searched but the bunker / fort is so big I tried several times. I can’t remember where I got the other three. Where could it be?


#30

I have tried to get the sniper rifle from the watchtower at Masskar but I just can’t get the yellow pick-up highlight around it. I’ve got up to the top of the pallets and can reach the body and I can SEE the rifle, but not pick it up. Soooo frustrating. Every time I jump I end up under the tower. Is there a special location of technique needed to get up there?

Two other locations:

Asotungan Outpost. I have found a revolver by one of the barricades and a sniper rifle on top of the hill near the watchtower but have scored all around both the road camp and the hilltop camp with no luck. Can anyone say where the other two guns are?

Finally Skogsbo Homestead, the house that’s burning with the staircase blocked. I found the gun outside by the churchyard body but there’s one more gun around the house and I can’t find it. Any help folks?


#31

You can get up. Climb onto the barrels jump on the ledge. Crouch, and work you way to the front, use little movements. When in front, try to stand up; you might need to backup a bit (again little movement). Do not fall off, and then jump up in the tower. I missed jumped a few times but I got it in the end.


#32

In Tosberga fort:

  1. 3* AG5 (-4631, 4338) in the 1st part of the bunker. Should be next to dead soldier.
  2. 4* .44 Magnum (-4543, 4500) in the 2nd part of the bunker, in long tunnel.
  3. 3* m/49 (-4509, 4500) in same tunnel as above weapon, a bit further down.
  4. 4* semi-auto shotty (-4500, 4500) almost next to the m/49.

Guide here: Interesting locations

  1. 1* .44 Magnum (-165, 2065)
  2. 1* .243 s-rifle (-187, 2038)
  3. 1* .270 s-rifle (-200, 2056)
  4. 1* .270 s-rifle (-242, 2050)
Screenshots

  1. 1* AG5 (136, 2812) at the cemetery.
  2. 1* Möller (168, 2863) inside the house.

Asotungan Outpost, missing weapons PS4
For people who want to know weapon locations ****spoilers****
Co-Op to Single Player Collectibles
Vastra Mark weapon location
#33

It was the shotgun. I past it many times, it was under a soldier hidden in the shadow. He’s on the right a few metres away from to me.


#34

Yes, its in the watch tower.

Facing it, jump on the left wooden support, crouch - carefully creep around the edge so you are facing the entry and can see the dead soldier - stand back up and spam forward jump.


#35

So I before I thought I had all weapon locations done, since I did not find any location (by mouse-over on location icons on the map) that indicated to me that there were weapons to collect. However today I was at Torsberga Fort taking photos and I got the message I only had 3/4 weapons from that location. I checked again after I found the 4th weapon. Moused-over Torsberga Fort safehouse but again no message. This means I have to travel to each safehouse to make sure that that location is completed 100%, because it does not show me on the map. Stats show that I have 175 completed.


#36

May be you can provide some more details on the Asotungan Outpost weapons? Like, some description or screens. Because I can’t find anything but 1 weapon (I even forgot what it was, maybe the rifle on the hill).


#37

Just added screens, under “Screenshots” tag (click on it to view).


#38

Huge thanks! But like I was afraid, I wouldn’t be able to MISS the rifles and a magnum. They are just not there. This is disappoiting. Completing the whole game and all the achievements but being not able to loot some damn guns just because someone got them before you and you just joined his game…
Got only 9 locations unlooted…


#39

It doesn’t go like that. Instead, it goes like this:

  • join MP game as client
  • pick up weapon in MP game (e.g weapons 1/4)
  • you got the weapon
  • get back in your game
  • game doesn’t register the weapon loot counter in your game (still shows: weapons 0/4)
  • since game knows you picked up the weapon, it won’t spawn 2nd one for you to pick up in your own game

#40

@Aesyle, you see, the point is that I haven’t been in Asotungan before that. In Himarvet, yes - I picked up KVM in the police station before I got there on my own (as part of the quest). But I wasn’t in Asotungan in MP game. And once I got there in SP I was able to find only rifle on the hill.

Anyway, I’m so tired of sneaking around the places and looking under every stone. Will check the weapons next time when I will install the game (with the new DLC or after new big patch).