Frequent random crashes preventing progress


#1

Platform: PC

Steps To Reproduce: Unsure

Images / Videos: None, but can be acquired if desired

Host or Client: Host

Players in your game: Just me

Specifications: Intel i5-4440 3.1 GHz, 32 GB ram, Windows 7 64-Bit, nVidia GTX 960

Have been trying to play the game persistently despite the crashes, fiddled with the settings to find a set up that worked but no luck. I was able to clear the first island and cross the bridge with minor difficulty, but before I could make it to the safe house in Salthamn I crashed to desktop. Ever since that crash I can barely leave the safe house I spawn into before crashing again and again. When it happens is not time based or location based as far as I have been able to see, but these crashes have entirely locked me out of all further progress. Verifying game files and reinstalling did nothing to mitigate or delay the crashes.

I have been watching your streams and heard in the most recent one you are hoping to get the patch out soon, I sincerely hope it can let me play this game and make progress again. It is an amazing concept and I like what I have seen/what I have been able to do so far.


Things I've already passed on to the devs to look at for future patches
Random crashes, but too frequent
#2

It could be because you are using Windows 7


#3

I would hope that is not the case as it is one of the system requirements.


#4

Your GTX 960, does it have 2gb of VRAM by any chance?

I’m running an R9 380 2gb and experiencing the same thing: Mostly smooth gameplay before Salthamn, then the game becomes highly unstable. After respawning in the bunker the game would run 2 - 15 minutes before crashing seemingly at random. According to the event viewer the issue is an Access Violation.

I just tried fast traveling back to the church to see how stable the first island is. I had not done “First Contact” at the castle, so I did that and except a few freezes I had no issues on the island. Passing Salthamn caused some more freezes, but I avoided looking at it as much as possible. Eventually I crashed after clearing the Naval Base … after 90 minutes total.

After some more failed attempts I tried slowing down: no sprinting, no sudden mouse movements, releasing controls when the game freezes … and while I still have random crashes they are not as frequent anymore. It’s still far from acceptable as I’m not really able to achieve anything in the 15-30 minutes I have.


#5

yes 2gb of vram. after the most recent patch it is about 15-30 minutes of play time as you described, have to release controls during freezes otherwise it crashes, slowing down every now and then when it begins to stutter frequently, etc. only difference i have between what you have described and my experience is now that the patch cam out, the opening island and the second one with salthhamn react the same.


#6

Played only for about a week, don’t know how things were before the patch.
Maybe I got lucky on the first island, because I wasn’t sprinting that much when I started to play and when I cleared the castle today. However there seem to be less objects compared to the rest of the game and no bunkers, so that may help just a bit.
I’ve also observed the game continuing to run even when the game freezes (ie aiming in another direction after the freeze when bumping the mouse during the freeze). Anyways …

Steps to reproduce:
Install graphics card with 2gb VRAM. Spawn inside the Salthamn Bunker and just sprint outside and further to the Naval Base west (seems to be a very reliable area). The game should crash somewhere along the way, if not try running further south to the lighthouse.

I keep seeing people with 2gb cards having the issue and it’s a memory related crash, so … guess we’ve narrowed it down as best as we could. Now it’s up to the devs to do something about it. :expressionless:

What’s funny though: By now I play on low settings completely. When I started I was on medium - high, which should mean more VRAM usage, but it doesn’t seem to make any difference.


#7

Thank you for the information, we\re looking into this! Apologies for the trouble.


#8

Been looking around some more. Another common thing I have noticed is Windows 7 (running Win 7 64 SP1 myself)…so much about me being observant. My bad! -.-


#9

They recently had a patch for win 7 players, cannot blame for missing it as it could have easily been removed as an option without thinking.


#10

Who released a Win7 patch? Am I missing something?

Asked google about “BEX64” and “StackHash_b4ee” which seem to point to the windows DEP … which I have no clue about.

Expanded my search and looked for similar issues with JC4 and HunterCOTW, which AFAIK use the same engine. And surprise: players were reporting random crashes every 5 - 30 minutes or so and these reports date back to late 2018 / early 2019.
This seems to be an issue with the Apex engine, not specifically GZ. COTW supposedly got a patch that fixed it, so … waiting it is I suppose.

Just to be sure I tested every single fix that’s suggested online. Literally all of them and too much to list here … which took about 3 hours including research. None of them solved the problem.

I’m not screwing with my system any more to get this game to run. Everything else runs perfectly stable, even if I push my PC to the limit.


#11

GZ released one, though i think it was labeled more as a hotfix then a patch.


#12

Nah, haven’t noticed a patch and I’m looking daily … because I must be mental.
Sorry for constantly causing a notification, but I kinda enjoy bumping since I’m unable to enjoy the game at all. :stuck_out_tongue:

I’m gonna leave a list of things I tried (in no particular order):

  • updating all drivers
  • installing all Win 7 updates
  • running as admin
  • underclocking my GPU (eliminating potential heat issues)
  • playing in offline mode
  • disabling cloud sync
  • disabling AV software
  • disabling Steam overlay
  • killing Steam completely after game launch
  • disabling Windows Aero
  • closing all non-essential software (including background processes like ATI overlay etc.)
  • every possible combination of in game settings
  • playing in window mode (sidenote: why is the cursor not restricted to the game window? ouch!)

NONE of these or any combination made a difference.
There is one more thing I’m going to try. It’s a stupid idea, I can’t call it by name, but I’m doing it anyways for research.

Unless there is a point in further discussion here I’ll stick to replying to new threads about the issue, telling people there is no fix and that the issue is seemingly being ignored.


Game crashed, no crash report
#13

It is not being ignored, this thread even has a post by one of the developers. The Win 7 hotfix they released was supposed to fix this issue, but did not. They are still looking into it, but more then likely it is not an easy one to track and fix since it has survived all the previous patches and hotfixes. You are a lot more persistent that I was though, any more things you find out about this would be of great help I am sure, so keep it up~. Would love to play the game again as well.


#15

Avalanche_Graham, thank you for responding to these posts finally. Haven’t seen a dev respond to a ‘random crashes’ post anywhere else. Wish the game was playable but it isn’t due to these crashes! Windows 10, 16gb ram, Geforce RTX 2080 w/ 8gb ram.


#16

BUMP

Installed May 28th patch. Played for around 30 minutes and crashed twice. Basically nothing has changed.

It’s so much fun testing this rushed early beta game. Great job!


#17

Any progress on this? I’m running Win 7 Home Pre (sp1), i5 2,67Ghz, 12 gb ram, Radeon Nitro+ RX580 oc 4gb.

Have been experiencing freezes 1-10 seconds long right from the start in the main menu and in the game. At first it seemed to be while entering new areas or reloading an area. I played around with the settings a bit going from high res and graphics on ultra to low res and graphics on medium-low, still experienced freezes a lot and crashes every 5-30 min.

I ran windows update (there was an update for .Net framework and something else) and checking for solutions on this forum and elsewhere. Then I just tried turning graphics back up to Ultra and High Res. Now it works fairly well, no freezes longer than 5 seconds and not to many (seeing as my CPU only meets minimum requirements). But still crashes every 5-30 min at random places. A few times when the game was closing down.

For me it’s playable on single player, but not much fun to play multiplayer if I’m gonna crash 2-8 times per session. And I mainly bought it to play with my friends.

Is there any known solution to this except upgrading the os to Win 10? (which I can’t know if it would fix it in my case and I’m not keen on upgrading it for one game…)


#18

Can we have some more details on your CPU? If it only meets minimum requirements it isn’t that optimal, especially if you try to run graphics settings on High or Ultra. Either way it’s likely that it won’t keep up with the Radeon RX580 (which is a decent card on it’s own) and will cause a bottleneck which affects gaming performance. I think that may be why your game’s freezing.


#19

Hello again! I kind of gave up right after posting my last post. I used to run an Intel Core i5 750 at 2,67ghz, but now I’ve got a cooler and overclocking at 3,6ghz.

I used to have random crashes before, every 5-30 min, and freezes all the time, like I wrote in august. But since the september update I’ve tried playing and there was Zero freezes and only one crash after 4 hours of playing with just two 5-min breaks when I left the game running. I’m getting hopeful that most crash-issues has been cleared out for me!

A thing to note is that I was running on Ultra graphics for the first 3 hours, then tried turning it down for a smoother experience the last hour. Maybe some of the changes there provoked the crash? Or maybe not…

I will try soon again and hope it doesn’t crash more than once every 4 hours. That would be absolutley awsome! Love the game!


#20

Hm, so, after playing 6 more hours I’ve had about 5-6 more crashes. The last one about 2-3 min in to the game. So the spread of crashes since last update is about 2-3 min to 4h apart. Very random. And only about half of the times it asks if I would like to send a crash report.


#21

Tried setting down the graphics and turning of v-sync. Still a crash after 5-10 min. Have had tre crashes nearby the bridge between Iboholmen and Södra Saltholmen now, at different places doing different things. But now it feels like I’m stuck on Iboholmen. :stuck_out_tongue_winking_eye: